An HTTP 401 Unauthorized response

MailEnable Exchange ActiveSync (EAS) - for EAS enabled devices (including iPhone, Windows Phone 7, Android, Nokia, etc).
Post Reply
Posts: 8
Joined: Sat Jul 21, 2012 11:22 am

An HTTP 401 Unauthorized response

Post by onemancrew » Wed Jul 25, 2012 1:17 pm

Hi all forum members , I encounter an issue with "Microsoft Exchange ActiveSync Connectivity Tests"

1) So I go to this URL:


and I choose "Microsoft Exchange ActiveSync Connectivity Tests" ---> Exchange ActiveSync


Then I Click Next


Then I choose "Use Autodiscover to detect settings"
and type AS email address:


Then I type As "Domain\User Name (or UPN)"


Then I type AS "Password"

the password for the email box as configured inside MailEnable.


Then I tick the following checkboxes:

a) "Ignore Trust for SSL" (Because I am using own SSL which I have issue to my self)

b) "understand that I must use the credentials of a working account from my Exchange domain to be able to test connectivity to it remotely. I also acknowledge that I am responsible for the management and security of this account"


The I click on "Preform Test" Button


The test is running and after the test process is finished then I get the following error msg:

Code: Select all

Attempting to send an Autodiscover POST request to potential Autodiscover URLs.

Autodiscover settings weren't obtained when the Autodiscover POST request was sent.

Test Steps

ExRCA is attempting to retrieve an XML Autodiscover response from URL for user

ExRCA failed to obtain an Autodiscover XML response.

Additional Details

An HTTP 401 Unauthorized response was received from the remote IIS6 server. This is usually the result of an incorrect username or password. If you are attempting to log onto an Office 365 service, ensure you are using your full User Principal Name (UPN).


what is strange ???

That I have configured the email box in the level of the Iphone without any problem.

so ActiveSync is working well in the level of the iphone , but when I run the tests which belong to Microsoft then I get the above error MSG.

what do you say about this ?

note: when I have configured the mail box inside the iphone , then I used username as following "exampleuser" (without @ and without address , means that I have typed as username in the level of the iphone only "exampleuser")

NOW , when you visit "

Code: Select all
" then in username field you required to type "Domain\User Name (or UPN)"

so I have tried the following:

and I have tried the following:


but in both tests I have recieved the same error msg regarding "An HTTP 401 Unauthorized response"

so what do you say about this ?

Post Reply