[SOLVED] Please Help

Raise/discuss any potential issues with MailEnable for consideration in project issue register.
Post Reply
naeemahmed
Posts: 8
Joined: Fri Nov 23, 2012 1:30 pm

[SOLVED] Please Help

Post by naeemahmed » Sun Nov 25, 2012 5:48 pm

Hello.

I will be appreciated if anybody goes from the same situation and have fixed the issue. Please read the following scenario what i am facing.

I am sending e-mail to one of my MailEnable hosted e-mail address and i sent out from my machine successfully and it did receive at the destination e-mail but it didn't route towards the mailbox it actually addressed to. I have seen the following message in MTA Debug log.

11/25/12 10:29:11 Processing file 47D778285702479CA9396BE476C5D974.MAI from queue SMTP
11/25/12 10:29:11 MTADeliverMessage::Executing external COM event pleskmemta.PleskMEMTA with message 47D778285702479CA9396BE476C5D974.MAI from SMTP queue
11/25/12 10:29:11 MTADeliverMessage:: COM Pickup Event pleskmemta.PleskMEMTA removed message 47D778285702479CA9396BE476C5D974.MAI.

According to this mail e-mail reached at its destination but MailEnable MTA Agent has done something with it and removed that message and didn't deliver to the corresponding mailbox. I have checked from MTA properties and its Enable Pickup Event option is turned off. If i turned it on. It asks me for a valid event pickup file / command. What should i write there.

I will be grateful if anybody helps me out.

Regards,

Naeem

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Re: Please Help

Post by MailEnable » Sun Nov 25, 2012 9:54 pm

MailEnable is functioning correctly.
The server will have Plesk installed, and they provide a addin to MailEnable (it is not a MailEnable provided component, so plesk presumably has an interface to configure it). In any case, it is that component that is deleting the message. You can turn off all addins in MailEnable under the options of the MTA - you should probably do this while you determine what is misconfigured under plesk.

http://www.mailenable.com/kb/Content/Ar ... D=me020497

In particular, these headings:
- Stopping the third party MTA Pick Up Event
- Stopping the third party COM object Pick Up Event (Mainly Plesk users)
Regards, Andrew

naeemahmed
Posts: 8
Joined: Fri Nov 23, 2012 1:30 pm

Re: Please Help

Post by naeemahmed » Mon Nov 26, 2012 5:13 am

Hello Andrew.

Thank you for your answer. Can you please let me know which particular Plesk component has to be viewed if it is causing this issue to happen or is there any help available so that i could do that from the Registry Editor of my Windows 2008 Server.

Awaiting for your earliest action and update on this matter please.

Naeem

naeemahmed
Posts: 8
Joined: Fri Nov 23, 2012 1:30 pm

Re: Please Help

Post by naeemahmed » Mon Nov 26, 2012 5:31 am

Hello Andrew.

I would like to inform you that i have successfully disable COM Pickup Event of Plesk from the Registry Editor. I have gone through with one of your knowledgebase reference and disable the COM event and after that i sent a test e-mail and it delivered to its mailbox without any issue.

I would like to thank you once again for helping me out.

Regards,

Naeem

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Re: Please Help

Post by MailEnable » Wed Nov 28, 2012 11:01 pm

No Problem, thanks
Regards, Andrew

Post Reply