Issue with bindings and Authentication Mode

Raise/discuss any potential issues with MailEnable for consideration in project issue register.
Post Reply
jcgilbert86
Posts: 1
Joined: Thu Jul 25, 2013 4:20 am

Issue with bindings and Authentication Mode

Post by jcgilbert86 » Thu Jul 25, 2013 4:41 am

I was unable to find anything on this so I figure I would post this in case it helps anyone else.

We are going through PCI compliance and using mail enable enterprise edition.
We fail PCI compliance because we are advertising smtp plain text authentication.

After doing research I found kb article: ME020583 - HOWTO: Preventing SMTP authentication through plain text connections.

After following the article it worked and we passed PCI compliance for the server. Today I made a change on the SMTP connector inbound tab. I change the IP bindings from "Always bind the service to all available ip addresses" to "only bind to these selected ip addresses" (I unchecked an IP address as we have two interfaces on the server).

It seems when you are not selecting all available addresses on the inbound binding the fix from article ME020583 does not work. I set the setting back to "Always bind the service to all available ip addresses" and the fix started working again. I verified by using telnet and the ehlo command.

I am not sure if anyone else is having the issue, but this worked for me and was verified on our secondary mail server running ME Enterprise Edt. also.

Post Reply