Lost election in MTA debug log

Discussions on webmail and the Professional version.
Post Reply
Posts: 227
Joined: Sun Aug 24, 2003 6:56 pm
Location: Denmark

Lost election in MTA debug log

Post by json » Sat Jul 29, 2006 7:36 am

What does this mean? Should I be alarmed?

07/29/06 09:14:27 Lost election.

In the debug log, and this in the activity log:

07/29/06 09:14:23 Unable to Load Plug-In Filter [MTAFILTER]

Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Sun Jul 30, 2006 3:01 am

The lost election entry in the event log could appear if another instance of the MTA was started. It is an information message only and is intended to indicate that MailEnable detected another instance of the MTA and the now current instance was denoted to a slave allowing another MTA instance to access the mailenable queues.
Regards, Andrew

Posts: 227
Joined: Sun Aug 24, 2003 6:56 pm
Location: Denmark

Post by json » Mon Jul 31, 2006 5:57 am

That doesn't sound nice!

I made a support issue when I installed the new version 2 of ME, and it failed.

Then I tried again, and it looked like it worked, but this problem, and the fact that neither Bayesian nor AV seems to be running (they should), forces me to reinstall the server. :cry:


Posts: 25
Joined: Fri Mar 20, 2015 7:53 pm

Re: Lost election in MTA debug log

Post by keith@vfsremote.com » Wed Aug 10, 2016 7:27 pm

For people who are having a similar issue in 2016:

I ran into this issue 2 days ago and it has been a nightmare. Inbound Queues were not processing. MTA took forever to start processing when restarted and had a lot of
"Lost Election to LS Connector..."
"Lost Election to POP Connector..."
"Lost Election to SMTP Connector..."

We thought it had something to do with Spam assassin pick up events.... nope
We thought it had something to do with the filters Enabled..... nope, but turning them all off helped marginally

The Cause: What really was happening was someone had turned on POP retrieval for an account that had an unknown number of emails in it. The POP inbound QUEUE was filling fast. I suspect pop retrieval settings on the server were not ideal

What I think was Happening: I believe the MTA was wrestling between the inbound SMTP load and the POP inbound load and simply couldn't keep up. I had excluded all of these messages from filtering by using a ..... FILTER. Guess what, that didn't help.

Solution: Turn off pop retrieval on the offending account, and empty pop inbound using the 2 below steps to back everything up

Move .mai from
\\Mail Enable\Queues\pop\inbound

Move .mai from
\\Mail Enable\Queues\pop\inbound\messages

With filters OFF I turned the MTA back on, once I saw it working again I turned on the filters 1 by 1

As soon as I saw those Lost Elections disappear.... I knew I had it.

Now I have to double check pop retrieval settings and maybe slowly drop messages back in

Good Luck!

Keith Damron
Manager of Customer Support

1250 E. Diehl Road, Suite 302
Naperville, IL 60563
630 553-0000 x112

Post Reply