Move Configuration Repository

Discussions on webmail and the Professional version.
Post Reply
proulier
Posts: 6
Joined: Thu Jun 05, 2014 1:34 am

Move Configuration Repository

Post by proulier » Thu Jun 12, 2014 3:30 pm

I installed ME8.5 Premium and accidentally accepted the default file locations during setup. I need the data to be stored on a different drive. When I try to reinstall, I do not get any prompts that would allow me to change the Repository folder location? When I try to re-install, there is no option to change folders.

Does anyone have any suggestions?

--Paul

frontdist
Posts: 17
Joined: Tue Mar 05, 2013 7:12 pm

Re: Move Configuration Repository

Post by frontdist » Tue Jun 17, 2014 2:29 pm

You'll have to actually move the configuration from where you put it to where you want it, then reset the permissions as per the below link.

http://www.mailenable.com/kb/content/vi ... D=ME020073

I had to set permissions manually through windows explorer, rather than command line as apparently in server 2012 the CACLS command is deprecated or changed. The :F part of the command I believe sets "full control" with the permission.

Also, if you look at the permissions on the config repository where it is now, they are different (meaning there are extra IME_ accounts) with permissions to the folder over and above what is specified in that link, however when I added only the ones they specify, it seemed to work fine.

Just be very careful, sometimes it doesn't work the way you would like - personally, having gone through it all before, I would just wipe the computer and start over doing it the way you want and setting the correct storage locations. You can try an uninstall/reinstall, but it never seems to take it back to a from-scratch point like wiping the computer does.

Post Reply