Ctriterion Script

Discussions on webmail and the Professional version.
Post Reply
Sonic Blue
Posts: 35
Joined: Fri Apr 18, 2003 6:28 pm

Ctriterion Script

Post by Sonic Blue » Fri Jan 09, 2015 4:33 pm

I have the following Criterion Script below.

Basically I have all of these e-mails which have the following line in the header that I am trying to match.

Code: Select all

X-ME-Spam: High (460)
I have verified (by changing the order) that this "Spam" filter is running after [System Spam Filter].
I had Debug Status enabled (that's how I found out that the [System Spam Filter] was putting the "high" in there after my "Spam" filter was running) but aside from pointing out the incorrect order there really is nothing useful. It simply says .

Code: Select all

Executed	CB761.MAI	SMTP	[System Spam Filter]	ADD_HEADER		[SMTP:POSTMASTER@removed1]	85.105.247.58	High (485)	Great answer to your health problems
Executed	FB3CA.MAI	SMTP	[System Spam Filter]	ADD_HEADER		[SMTP:sales@removed2.com]	117.3.61.76	High (460)	Make money more often!
Executed	D03DB.MAI	SF	[System Spam Filter]	ADD_HEADER		[SMTP:sales@removed2.com]	117.3.61.76	High (460)	
Executed	D03DB.MAI	SF	Spam	ADD_HEADER,ADD_SUBJECT_PREFIX		[SMTP:sales@removed2.com]	117.3.61.76	SCRIPT	
Executed	7D95C.MAI	SMTP	[System Spam Filter]	ADD_HEADER		[SMTP:agraphia@removed3.info]	72.1.240.221	High (460)	Insure those expensive holiday gifts with Choice Home Warranty. 
Executed	74479.MAI	SMTP	[System Spam Filter]	ADD_HEADER		[SMTP:POSTMASTER@removed1]	37.57.101.76	High (485)	Verified Forum
The odd thing is that while all of the e-mails I've looked at contain the above header only about 3-5% are actually matching the rul and are having their Subject being prefixed with "[Spam]" and the Deliver-To=Junk added to the mail header.

As you can see from the above log Lines 1, 2, 3, 5 and 6 are all having the High (4** added.
But only line 3 is matching the below script and getting the ADD Header / Add Subject Prefix.

I am at a loss as they've not authenticated.

This is running ME Professional 8.64 64-bit.

Code: Select all

FilterResult = 0
If [ME_SENDERAUTH] = 0 Then 
    If CriteriaMet([ME_HEADERS_CONTAIN],"*High (4*") Then
        FilterResult=1
    END IF
END IF 
Thanks,

Post Reply