MailEnable WebServices - Slow Response

Discussion for developers using MailEnable.
Post Reply
dkan
Posts: 4
Joined: Wed Jul 17, 2019 9:26 am

MailEnable WebServices - Slow Response

Post by dkan » Wed Oct 30, 2019 10:38 am

Hello,

I am currently developing a solution for intergrating with Mailenable server from a third-party application using webservices. To be more precise, my approach is similar to automation shown here, at "Parallels Plesk Automation Integration" section (http://www.mailenable.com/addons_Management.asp).

I have already developed "Add Mailbox" and "Get Mailbox" functionality.

"Get Mailbox" asks details about all mailboxes (about 10 mailboxes) in a postoffice in order to get quota for each one of them and here are the results:

- When trying from third party application, each request (for each mailbox) takes about 2 seconds. Weirdly enough is the fact that the first request takes about 5 seconds

-When trying to make requests from the server itself, each one takes about 1.5 seconds.

"Add Mailbox" creates a new mailbox, performance is the same as described above.

Is it normal such a performance? I wonder why the first request takes so long and if I could achieve better results than 1.5-2 seconds per request.

I have checked server's cpu/ram/network usage and seems to be fairly low.

RandonDude
Posts: 1
Joined: Mon Nov 04, 2019 10:14 pm

Re: MailEnable WebServices - Slow Response

Post by RandonDude » Mon Nov 04, 2019 10:18 pm

Hi dkan,

i am facing the exact same problem. I got a Plesk Windows Server with best hardware and internet connection. (400€ / month)

I installed MailEnable 10.27 on Plesk. Created 1 mailbox and migrated 10.000 Mails via Outlook. Upload AND Download for these mails takes 2-3 hours. Normally it should be done in 4-5 minutes.

Do you got a resolution? I am thinking to change mail server system. (SM)
People in this forum were posting in 2008 the same issue. Dafuq?! :cry:

dkan
Posts: 4
Joined: Wed Jul 17, 2019 9:26 am

Re: MailEnable WebServices - Slow Response

Post by dkan » Fri Jan 10, 2020 11:53 am

Hello,

It seems to me that Plesk is somehow slows down server. I have decided to install mailenable to another server.

Post Reply