Advanced Scripting not working as I would expect

Discussion forum for Enterprise Edition.
Post Reply
dustin
Posts: 34
Joined: Fri Jan 07, 2011 6:34 pm

Advanced Scripting not working as I would expect

Post by dustin » Tue Dec 31, 2013 8:06 pm

I've created the following system filter (with the IPs changed):

Code: Select all

If CriteriaMet([ME_IPADDRESS],"1.2.1.*") OR _
     CriteriaMet([ME_IPADDRESS],"1.2.2.*") OR _
     CriteriaMet([ME_IPADDRESS],"1.2.3.*")  Then
     FilterResult=1
End If
yet e-mails coming from other IP addresses are causing the filter to match and the action that I've set to be triggered. Can someone explain why?

dustin
Posts: 34
Joined: Fri Jan 07, 2011 6:34 pm

Re: Advanced Scripting not working as I would expect

Post by dustin » Tue Dec 31, 2013 8:10 pm

Added

Code: Select all

FilterResult=0
to the beginning of the script just to make sure that's not the issue. I'll report back.

dustin
Posts: 34
Joined: Fri Jan 07, 2011 6:34 pm

Re: Advanced Scripting not working as I would expect

Post by dustin » Tue Dec 31, 2013 8:28 pm

That might have been the culprit. That, and not restarting the MTA after my changes.

dustin
Posts: 34
Joined: Fri Jan 07, 2011 6:34 pm

Re: Advanced Scripting not working as I would expect

Post by dustin » Thu Jan 02, 2014 4:58 pm

The filtering engine is definitely buggy. /rant

dustin
Posts: 34
Joined: Fri Jan 07, 2011 6:34 pm

Re: Advanced Scripting not working as I would expect

Post by dustin » Thu Jan 02, 2014 5:33 pm

dustin wrote:The filtering engine is definitely buggy. /rant
It appears that adding

Code: Select all

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mail Enable\Mail Enable\Agents\MTA\Filters\MTAFILTER\Debug Status
as per http://www.mailenable.com/mailenable/he ... ipting.asp causes the filter to not trigger, at least in my case. When I removed the key, my filter started working again. I created the key in order to see if I could find out why ME_SPAMASSASSIN wasn't triggering in my script yet the outbound headers showed it as having failed SA.

Post Reply