IMAP service hangs issue

Discussion forum for Enterprise Edition.
yousafalvi
Posts: 3
Joined: Mon Apr 29, 2013 8:34 am

IMAP service hangs issue

Post by yousafalvi » Mon May 26, 2014 9:24 am

Hello
i am using Mailenable enterprise 6.5 edition
all users are using IMAP logins i am facing the problem since week before that IMAP service hangs its shows green as started in service section
but users are not able to sync their mails or folders it gives the error of time out, when i restarts the service all mailboxes and email logins starts working fine

can you guys please help me on this issue

Regards

MailEnable-Ian
Site Admin
Posts: 9321
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP service hangs issue

Post by MailEnable-Ian » Tue May 27, 2014 12:48 am

Hi,

You need to first upgrade to the latest version 6.87 from the link below to eliminate problems in the 6.5 your running.

Enterprise: http://www.mailenable.com/Enterprise687.exe
Enterprise Premium: http://www.mailenable.com/Premium687.exe
Regards,

Ian Margarone
MailEnable Support

isaak
Posts: 476
Joined: Sat Nov 11, 2006 12:10 am

Re: IMAP service hangs issue

Post by isaak » Tue May 27, 2014 7:32 pm

Hi, I am experiencing the same issue. Running PREMIUM 8.5.

IMAP hangs after a while and service shows as running. Then manually restart the IMAP service and all IMAP clients can connect again.


Note: I believe OP means 8.5 instead of 6.5.

MailEnable-Ian
Site Admin
Posts: 9321
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP service hangs issue

Post by MailEnable-Ian » Wed May 28, 2014 12:19 am

Hi,

Well if 8.50 then it would be ideal lodging a support ticket and providing the following details when you lodge the ticket:

1. IMAP activity and debug log files. You may want to set the IMAP debug log to a higher level of debug logging so that it will provide information as to what the service is doing at the time of the problem. Information on how to enable higher level debug logging for the MailEnable services can be found within the following article: http://www.mailenable.com/kb/viewarticl ... 020585.htm. Specify details of the date/times the unresponsive occurs.

2. Details of how may concurrent connections are connected to the IMAP service at the time of the problem. You can gain this information by inspecting the "Metray" utility under the "Real time activity" tab within the IMAP section.

3. Windows task manager information about the IMAP process. I.e. Memory usage at the time of the problem.

4. Any Windows event log errors that are logged in regards to the MailEnable and the IMAP Service at the time of the problem.

5. RDP or a Teamviewer session so a technician can login at the time of the problem to troubleshoot the problem live on server.
Regards,

Ian Margarone
MailEnable Support

isaak
Posts: 476
Joined: Sat Nov 11, 2006 12:10 am

Re: IMAP service hangs issue

Post by isaak » Wed May 28, 2014 5:07 pm

I have already lodged a support ticket and provided with all the details requested here. Let us see what can ME do with this case and provide a fix as soon as possible.

benmutlu
Posts: 23
Joined: Mon Dec 27, 2010 12:31 pm

Re: IMAP service hangs issue

Post by benmutlu » Mon Jun 29, 2015 3:33 pm

Any news about problem ? Did you solve ?

I have kinda same problem since 1 week, randomly IMAP service hangs , there is no proper log , no issue, have to restart IMAP service to fix.
I reinstalled everything, still having problems..

8.50 Ent prem.

MailEnable-Ian
Site Admin
Posts: 9321
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP service hangs issue

Post by MailEnable-Ian » Tue Jun 30, 2015 1:17 am

Hi,
Any news about problem ? Did you solve ?

I have kinda same problem since 1 week, randomly IMAP service hangs , there is no proper log , no issue, have to restart IMAP service to fix.
I reinstalled everything, still having problems..

8.50 Ent prem.
You need to first upgrade to 8.60 and retest as 8.50 is outdated and contains issues you need to address.
Regards,

Ian Margarone
MailEnable Support

jamierichiesy
Posts: 5
Joined: Wed Jul 15, 2015 6:52 am

Re: IMAP service hangs issue

Post by jamierichiesy » Thu Aug 06, 2015 2:50 am

I have the same problem with v8.60 after restart the users can connect again

bfonseca
Posts: 22
Joined: Wed Oct 27, 2010 5:25 pm

Re: IMAP service hangs issue

Post by bfonseca » Wed Aug 12, 2015 5:25 pm

We are experiencing the same issue. I am running Enterprise Premium 8.60 on a 2012 r2 server. Is there a resolution in the works for this ?

MailEnable-Ian
Site Admin
Posts: 9321
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP service hangs issue

Post by MailEnable-Ian » Thu Aug 13, 2015 1:10 am

Hi,
We are experiencing the same issue. I am running Enterprise Premium 8.60 on a 2012 r2 server. Is there a resolution in the works for this ?
I have the same problem with v8.60 after restart the users can connect again
Please lodge a support ticket via our support form for a managed response to your problem with IMAP. In your ticket please provide IMAP activity and debug log files and RDP or TeamViewer access to the server so the technician can troubleshoot in more detail.

http://www.mailenable.com/support/SupportRequest.asp
Regards,

Ian Margarone
MailEnable Support

BitekNathan
Posts: 1
Joined: Thu Aug 13, 2015 10:45 pm

Re: IMAP service hangs issue

Post by BitekNathan » Thu Aug 13, 2015 11:00 pm

Just letting you know. I am also experiencing this error. On two occasions in the last week it has caused a full system crash requiring a power cycle of the server. I upgraded to 8.60 yesterday morning however the issue remains. I will also be lodging a support ticket and I eagerly await a working solution as daily service interruption is not acceptable.

benmutlu
Posts: 23
Joined: Mon Dec 27, 2010 12:31 pm

Re: IMAP service hangs issue

Post by benmutlu » Fri Aug 14, 2015 7:59 am

I had same issue, I did everything for solution.
I reinstalled, reconfigured, checked all hardware defect etc..

And I started to monitor realtime activity, and I make a list from online users when IMAP service hangs. I figure out when IMAP crash I had same user everytime, I checked his mailbox and I see that there is about 15 folder in inbox at server side, but about 13 in Outlook Imap folders. I deleted all mailboxes, and I recreate than IMAP crash never happened.

I told this to Ian from mailenable, but they said that its not related.

aisonet
Posts: 4
Joined: Sat Feb 21, 2015 1:30 am
Location: California, USA

Re: IMAP service hangs issue

Post by aisonet » Fri Aug 14, 2015 1:46 pm

We have the same issue in our ME Ent cluster, frequent IMAP crashing, missing emails that come back after a period of time yet can be seen in webmail the whole time, IMAP just stops responding, and only fixes so far are rebooting all the servers in the ME cluster and we are running the latest version of ME, 8.60.

noamway
Posts: 59
Joined: Sat Aug 12, 2006 5:11 am

Re: IMAP service hangs issue

Post by noamway » Thu Oct 29, 2015 9:31 pm

We also have the same problem for a long time.

sagelike
Posts: 309
Joined: Fri Feb 23, 2007 4:58 am

Re: IMAP service hangs issue

Post by sagelike » Fri Nov 13, 2015 4:46 pm

Same problem here with ME 8.6 Enterprise Windows Server 2008. IMAP restart fixes the problem.

I've used to telnet to check while it's hanging and I can connect locally.

IMAP debug log shows only this repeatedly: 11/13/15 09:34:16 [4788] Send failed (error 10053). Size 8192

I had about 190 IMAP connections at last hang using 7 of 8 GB of RAM.

Post Reply