Incoming messages stop when I change the default SMTP port!

Discussion forum for Enterprise Edition.
Post Reply
iltera
Posts: 31
Joined: Wed Aug 14, 2013 5:58 pm

Incoming messages stop when I change the default SMTP port!

Post by iltera » Thu Aug 28, 2014 10:04 pm

The default SMTP inbound port is 25. Most of us configure an alternate port for SMTP (like 587), because port 25 is blocked by the ISPs. Yesterday, I got a task to configure our Enterprise Premium mail server to also allow SSL connections. For that, as far as I know, I needed to configure port 465 as alternate port and set it to require SSL.

Here is the problem! When I change the default port 25, I cannot receive any incoming mails. That is very interesting because SMTP is used to send, not receive. I can send new mail, but cannot receive anything. Is that a bug or there are other things I should be checking?

What I want is to change the default SMTP port from 25 to 587, and the alternate port from 587 to 465 and configure it to require SSL. Will that configuration work for both secure and nonsecure connections?

Thanks in advance for all the contributions.

Regards,@

Brett Rowbotham
Posts: 542
Joined: Mon Nov 03, 2003 7:48 am
Location: Cape Town

Re: Incoming messages stop when I change the default SMTP po

Post by Brett Rowbotham » Fri Aug 29, 2014 4:58 am

Changing the default SMTP inbound port from 25 to something is a big no-no, unless you want a strictly private email server. Port 25 is used for both sending and receiving locally AND externally. No other email server in the world will know which port to use in order to contact your email server so you will not be receiving any email at all.

When an ISP blocks port 25 it is normally only for outbound traffic.

Reset your default port to 25 and you will once again receive emails from outside.

Regards,
Brett

iltera
Posts: 31
Joined: Wed Aug 14, 2013 5:58 pm

Re: Incoming messages stop when I change the default SMTP po

Post by iltera » Fri Aug 29, 2014 5:12 am

Thank you for your answer, Brett.

So, about my reason for changing that port, is it possible to use secure and unsecure connections at the same server? After your answer, I cannot see how anymore :(

Brett Rowbotham
Posts: 542
Joined: Mon Nov 03, 2003 7:48 am
Location: Cape Town

Re: Incoming messages stop when I change the default SMTP po

Post by Brett Rowbotham » Fri Aug 29, 2014 5:49 am

Why do you want to change both SMTP ports ?

If you leave the default at 25 then you are visible from outside. Set the alternate port to 567 or whatever you need, enable SSL on that port and then set your client email programs to use the alternate port rather than 25.

Cheers,
Brett

iltera
Posts: 31
Joined: Wed Aug 14, 2013 5:58 pm

Re: Incoming messages stop when I change the default SMTP po

Post by iltera » Fri Aug 29, 2014 6:07 am

Himmm... I can use the same port also with SSL, then... I just thought that I need to seperate secure and unsecure connections with different ports.
I am definitely gonna give that a try :)

Thanks!

iltera
Posts: 31
Joined: Wed Aug 14, 2013 5:58 pm

Re: Incoming messages stop when I change the default SMTP po

Post by iltera » Fri Aug 29, 2014 9:22 am

And I tried it. I could manage to configure two email accounts (one using secure connections, other with non-secure) on my Outlook 2013. But when it comes to my android 4 phone, the default email client gives an error when using "SSL/TLS (Accept all certificates)" option. The error is like;

SSL23_GET_SERVER_HELLO:unknown protocol

When I googled it, I saw that this is en exception on the SSL library when people send https requests over http ports. That means, I am trying to connect to my mail server using SSL, over the non-secure 587 port. That port should have been 465. I guess when it comes to secure connections, some programs realy check the usage of neccessary ports like the default android mail app.

I am using a self-signed cert, I don't think that it is, but do you think that may be the reason of that error?

Brett Rowbotham
Posts: 542
Joined: Mon Nov 03, 2003 7:48 am
Location: Cape Town

Re: Incoming messages stop when I change the default SMTP po

Post by Brett Rowbotham » Fri Aug 29, 2014 10:01 am

I don't use SSL on my email server so I am no help to you there.

Here is some information about port settings that might be useful to you:

https://www.fastmail.fm/help/technical/ ... rttls.html

Cheers,
Brett

iltera
Posts: 31
Joined: Wed Aug 14, 2013 5:58 pm

Re: Incoming messages stop when I change the default SMTP po

Post by iltera » Fri Aug 29, 2014 3:08 pm

Thanks, I managed to use the same unsecure ports (110, 143, 587) using Starttls option on my phone. That works well. Now, I am struggling with IMAP. IMAP doesn't offer a TLS connection method on the configuration screen and I cannot use that workaround for it. I created a new thread under MailEnable Connector for Microsoft Outlook section. You're welcome to have a look there.

Thank you, again, for your answers. You were very helpful :)

Post Reply