MailEnable Diagnostic Utility reports Invalid System Entries


SYMPTOMS

When running the MailEnable Diagnostic Utility it fails in the Configuration and Data Test with the error  "Invalid System Entries".

CAUSE

This error can mean that the ADDRESS-MAP.TAB configuration file MailEnable uses to store mailbox details may be corrupted or is missing critical system entries. Errors in this file can have varying degrees of effects from minor slowness in successful system lookups right through to lookup failures and non delivery of mail.

When using the  Tab Delimited files storage means (this is by default) there may be missing entries or incomplete formatting in the ADDRESS-MAP.TAB file located in the Program Files\Mail Enable\Config directory.  If you open the file using Microsoft Notepad it is usually easy to notice where the corruptions lie as the format of the columns will be visually not aligned or inconsistencies in the format of the file exist.

If the issue in not immediately noticeable then the format of the ADDRESS-MAP.TAB file is described in the System Manual (under the MailEnable Program Group), use the information supplied within to check the lines of your address-map file.

The above will differ when searching for the corruption while using a database storage provider but what to locate does not change again search for corruptions or entries that may be missing from the ADDRESS_MAP table of the MailEnable database.

RESOLUTION

Open the ADDRESS-MAP.TAB file located in the Program Files\Mail Enable\Config directory and verify its contents, not only searching for obvious format inconsistencies but also data fields that are not correct or contain incorrect characters.

There is also a system route entry that must be at the top of every ADDRESS-MAP.TAB file/table.  Each 
file/table at the beginning should have the following line that will initiate routing to non-local SMTP
addresses:
[SMTP:*]{TAB}{TAB}0{TAB}System
With the formatting extract above the {TAB} represents the TAB character. TAB is the result of pressing 
the TAB key on the keyboard.
MORE INFORMATION

How to access the MailEnable Diagnostic Report:http://www.mailenable.com/kb/content/article.asp?ID=ME020136

Invalid PATH Environment Variable error reported in diagnostic utility: http://www.mailenable.com/kb/content/article.asp?ID=ME020090

Diagnostic Report reports the error: 'Could not resolve your Local Domain Name in DNS':http://www.mailenable.com/kb/content/article.asp?ID=ME020183



Product:MailEnable (All Versions)
Article:ME020215
Module:General
Keywords:address,map,invalid,Invalid,sytem,entries,Configuration,Data,Test
Class:PRB: Product Problem or Issue
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable