ME020615 - TRB: LDAP service does not start


SYMPTOMS

When the LDAP service is started it stops immediately with an error. The Windows event log shows the error:

The MailEnable LDAP Service service terminated with the following service-specific error:
The directory cannot be removed.

CAUSE

This occurs if the server already has a service using the LDAP default port (port 389). The MailEnable LDAP service is unable to bind to the port, so exits.

RESOLUTION

To resolve you can either stop the other application that is using the port, or you can configure the LDAP service to bind to another port. In order to change the port number for the LDAP service you will need to add the following registry key:

For 32bit Windows:


[HKEY_LOCAL_MACHINE\SOFTWARE\Mail Enable\Mail Enable\Services\LDAP\Parameters]
"URLs"="ldap://localhost:9049/"

For 64bit Windows:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mail Enable\Mail Enable\Services\LDAP\Parameters]
"URLs"="ldap://localhost:9049/"


You will need to stop and start the LDAP service to have changes be effective.

 



Product:MailEnable
Category:Other
Module:General
Keywords:
Class:TRB: Troubleshooting (Configuration or Environment)
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable