SUMMARY
Various error codes that can be returned and displayed in the MailEnable log files.
DETAIL
MailEnable logs socket errors in the SMTP
Debug Log file. Socket errors occur because the TCP/IP session between two
computers was either interrupted or was closed by either party. The following
sections label socket return codes and outline possible
causes.
10053 : (WSAECONNABORTED) - Software caused
connection abort. (recv) socket
[424] timeout during [] command from host 10.0.0.27. Socket was disconnected -
Return Value: ( 10053 )
Meaning: Software caused
connection abort. An established connection was aborted by the software in the
host computer, possibly due to a data transmission time-out or protocol error.
This means that there was a communications failure while data was being sent
or received from/by MailEnable. MailEnable was either expecting to
receive a response from a remote server, but did not receive the response in an
acceptable timeframe.
Probable Cause: The most likely causes
of this issue are:
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Faulty network card |
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Bad or incompatible network card
drivers |
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Unstable network connectivity
(e.g. faulty router or bad carrier)
| |
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Firewall intervention - a local
or external firewall prevented the transmission or receipt of data
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Invalid MTU settings on network card, please see: http://www.mailenable.com.au/kb/viewarticle.asp?aid=63<
/A>
|
10054 : (WSAECONNRESET) - Connection reset by
peer. (recv)
socket [424] timeout during [] command from host 10.0.0.27. Socket was
disconnected - Return Value: ( 10054 )
Meaning: An existing connection was
forcibly closed by the remote mail server or mail client application. This
normally results if the remote mail server/mail client application is suddenly
stopped, the host is rebooted, the host or remote network interface is disabled,
or the remote host uses a hard close. This error may also result if a connection
was broken due to keep-alive activity detecting a failure while one or more
operations are in progress.
Probable Cause: The most likely
causes of this issue are:
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Ungraceful rejection by remote mail host or mail client application. The remote
mail server or mail client terminated its session with
MailEnable without negotiating the appropriate closing sequence. The most likely reason for
this is that you are blacklisted because your server is (or was) open
relay. This can be confirmed by using the SPAM lookup utility at DNS Stuff
. Confirm if the server is open relay
by using the MailEnable Remote Diagnostic Utility . |
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Faulty network card/network card
drivers |
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Remote host failed, or was
rebooted/unstable remote host computer. |
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Port scan - someone has
run a TCP/IP utility against the server to determine what services are
running. Some ISPs may do this to determine what software is being used.
| 10060 : (WSAECONNTIMEOUT) - Software caused
connection abort. Socket was
disconnected - Return Value: ( 10060 )
Meaning: This error indicates that
MailEnable dropped the connection because it did not receive data in a timely
fashion.
Probable Cause:
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The remote mail server is not
sending the end of data command correctly. Some Unix mail servers and Perl
mail scripts violate the RFC and send "." to terminate the DATA command. In
this situation, the remote server is in error - but some mail servers do
allow/accommodate for this. |
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The remote mail server is
expecting MailEnable to terminate the connection (which again violates the
RFC).
| |
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The remote mail server is a
spammer
| | The remote server is temporary (i.e.
dialup) - most likely spammer or dubious. MailEnable is more adherent to the
RFCs than other mail servers with regard to end of DATA - primarily because
it means we are more impervious to spam.
|
MORE INFORMATION
Troubleshooting Mail Client Connectivity to
MailEnable:Article ME020075
Error 10038 when communicating with remote hosts:Article ME020238
How to
troubleshoot SMTP Connectivity issues and Analyse Log Files:Article ME020170 |