Folders do not sync when certain resources are connected to Outlook

MailEnable's Connector for Microsoft Outlook provides a rich messaging and collaborative interface to MailEnable.
Post Reply
kevvy
Posts: 6
Joined: Sat Sep 27, 2008 9:37 pm

Folders do not sync when certain resources are connected to Outlook

Post by kevvy » Fri Sep 24, 2021 9:31 pm

Hi -

We're using:

Outlook 365 - Version 2102 (Build 13801.20960 Click-to-Run)
MailEnable Enterprise - 10.36
MailEnable Connector - 2.75

I haven't had a resource added to my Outlook for over a year and needed to add one a few days ago.

The resource (another user's folder that I was granted full access to) was added to my Outlook, and the messages appeared in it. After restarting Outlook as instructed, I realized after a few hours that my Sent Items folder didn't contain the messages I sent since the resource was added.

After removing the shared resource, the issue went away (however, the messages I sent while it was added did NOT appear even though the "Reconciling Messages" dialog box appeared.) The messages were sent as I had several exchanges with people.... my replies aren't in my Sent folder. I also checked on the server to ensure they aren't there.

Performed some additional troubleshooting including restarting machine, repairing Office, re-registering the Connector DLL, etc. and the issue did not go away.

Though not 100% sure, it appears that if the shared resource has more than one person granted access to it, the issue occurs... for resources that only have me granted access to it, everything works OK.

Any guidance on fixing this issue would be appreciated. Thanks.

Kevin

MailEnable-Ian
Site Admin
Posts: 9547
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Folders do not sync when certain resources are connected to Outlook

Post by MailEnable-Ian » Sun Sep 26, 2021 11:36 pm

Hi,

Best way forward is to connect the share again and enable MAPI client side logging at full detail log level. Emulate the issue when sending the message. The log file will contain more detail when the message was transacted via SMTP. Search the log file for MESAVETOSENT.

http://www.mailenable.com/kb/content/article.asp?ID=me020589
Regards,

Ian Margarone
MailEnable Support

kevvy
Posts: 6
Joined: Sat Sep 27, 2008 9:37 pm

Re: Folders do not sync when certain resources are connected to Outlook

Post by kevvy » Tue Sep 28, 2021 3:21 am

Hi Ian -

I made the change (see attached) and although the log file was 300+ MB, I didn't find MESAVETOSENT.

I did see a few:

250-XSAVETOSENT
250-X-SAVETOSENT

after AUTH=LOGIN but am guessing that is not related.

Also seeing the following (replaced mailbox folder with <folder>):

2021-09-27 23:01:26.045 ME-IXXXX: (21012) [FOLDERCONTENTLIST::AddContentItem] Added item to Sent Items for <username> - server UID: 11E7865487A142C3BC7F9707D3CCB56E.MAI; Outlook EID: (70:000000001F609589044A2A44A9E89A3BFCDD8C640700C3B68E10F77511CEB4CD00AA00BBB6E600000000000E0000C3B68E10F77511CEB4CD00AA00BBB6E600008B0105000000).
2021-09-27 23:01:26.045 ME-IXXXX: (21012) [FOLDERCONTENTLIST::ProcessBatchAdditions] Added batch of 2 items to Sent Items.
2021-09-27 23:01:26.045 ME-IXXXX: (21012) [FOLDERCONTENTLIST::Synchronise_ServerChanges] NumDeletedFromOutlookStore (0).
2021-09-27 23:01:26.047 ME-IXXXX: (21012) [FOLDERCONTENTLIST::Save] Processing save request on (<folder>/Sent Items/Index.idx)
2021-09-27 23:01:26.086 ME-IXXXX: (21012) [FOLDERCONTENTLIST::Save] Saving 10623 items to (<folder>/Sent Items/Index.idx)
2021-09-27 23:01:26.087 ME-EXXXX: (21012) [FOLDERCONTENTLIST::Synchronize] FOLDERCONTENTLIST::Synchronize Completed with status:1
2021-09-27 23:01:26.088 ME-IXXXX: (21012) [FOLDERCONTENTLIST::Save] Processing save request on (<folder>/Sent Items/Index.idx)
2021-09-27 23:01:26.089 ME-IXXXX: (21012) [FOLDERCONTENTLIST::Save] Abandoned save request for (<folder>/Sent Items/Index.idx) since it is marked as clean

Does this provide any clues and/or any other suggestions of items to look for?

Kevin
Attachments
2021-09-27_23-08-55.jpg
2021-09-27_23-08-55.jpg (63.96 KiB) Viewed 1349 times

MailEnable-Ian
Site Admin
Posts: 9547
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Folders do not sync when certain resources are connected to Outlook

Post by MailEnable-Ian » Wed Sep 29, 2021 1:46 am

Hi,

You will need to lodge a support ticket and provide access to an example mailbox we can setup on our end and provide steps to reproduce the behavior. Also providing the full MAPI client side logs help.
Regards,

Ian Margarone
MailEnable Support

Post Reply