WIndows 2012 updates cause issue with MailEnableAppPool.

Raise/discuss any potential issues with MailEnable for consideration in project issue register.
Post Reply
robertmac
Posts: 10
Joined: Fri Jan 09, 2009 7:45 pm

WIndows 2012 updates cause issue with MailEnableAppPool.

Post by robertmac » Mon Nov 16, 2020 4:09 pm

Hi,

The last update to Windows 2012 R2 caused issues with MailEnableAppPool and web mail and web admin.

When trying to access web mail , users get error 503 service not available.

Event Viewer shows events with ID 2280 and 5139 five times in a row. After that, the Event with ID 5002 appears and the application pool is stopped:

Event ID 2280:

The Module DLL C:\Windows\System32\inetsrv\ModSecurityIIS.dll failed to load. The data is the error.

Event ID 5139:

A listener channel for protocol 'http' in worker process '12864' serving application pool 'MailEnableAppPool' reported a listener channel failure. The data field contains the error number.

Event ID 5002:

Application pool 'MailEnableAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.


I have tried MEinstaller did the following:

Selected the option for Web application reconfigure.
When prompted, entered a random password for your MailEnable account.
Did a Re-Register Administration (MCC) Components option followed by Set .NET Framework version for web applications.
restarted IIS and got same issue.

I saw that Plesk knowledgebase had come across the same problem and their fix was to update the C++ redistributables , which I did.

That also did not fix the issue.

https://mail-setup.com/webmail-error-503

I updated to latest version of ME enterprise, and that also did not fix the problem.

The only way to fix it was to restore back up before MS update and now it works.

So something in the updates is causing the MailEnableAppPool to crash.

Regards,
Robert

MailEnable-Ian
Site Admin
Posts: 9253
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: WIndows 2012 updates cause issue with MailEnableAppPool.

Post by MailEnable-Ian » Wed Nov 18, 2020 12:54 am

Hi,

From the event log error it looks like you are running IIS modesecurity plugins. This is not installed by MailEnable and my guess might be a Plesk plugin. We have seen that this can restrict page requests and therefore recommend you disable it or review the applications documentation on how to whitelist extensions.
Regards,

Ian Margarone
MailEnable Support

robertmac
Posts: 10
Joined: Fri Jan 09, 2009 7:45 pm

Re: WIndows 2012 updates cause issue with MailEnableAppPool.

Post by robertmac » Wed Nov 18, 2020 1:46 am

Hi,

No, I posted the event log from the web site.

I had the same errors but different module. The same event IDs and same number of errors.

Plesk is not installed on this server.

Since we restored from backups, do not have the original event log entries.

We turned off windows updates so the server can stay up. But that is just a short term solution.

Could it be the .Net framework patches that caused the problem?

Regards,
Robert

MailEnable-Ian
Site Admin
Posts: 9253
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: WIndows 2012 updates cause issue with MailEnableAppPool.

Post by MailEnable-Ian » Mon Nov 23, 2020 12:35 am

Hi,

We are not aware of any issues with the latest .NET framework versions and recommend that all .NET service packs are installed and up to date. You might want to ensure that your running 4.0 64bit Framework as well. But as mentioned the example event log error you pointed out in your original post is related to an IIS module that is failing. If you get stuck the best way forward would be to lodge a support ticket via our support form and provide access to the server.
Regards,

Ian Margarone
MailEnable Support

Post Reply