issue with sender and reply to email address being changed

Raise/discuss any potential issues with MailEnable for consideration in project issue register.
Post Reply
robertmac
Posts: 12
Joined: Fri Jan 09, 2009 7:45 pm

issue with sender and reply to email address being changed

Post by robertmac » Wed Dec 02, 2020 2:25 pm

Hi,

Having a strange issue with sender and reply to email address domain being changed from actual domain of sender to mail server host name.

This is only happening when the recipient of the email is in a secure medical environment.

For example: sender test@mydomain.com is replaced with test@mail.malhostdomain.com.

This is only happening on certain domains senders on the server. We have tried sending test emails from other domains/postoffices on the server and the problem does not occur.

The problem will occur if sent via webmail or an email client like outlook and thunderbird.

In the headers you clearly see the replacement . the sender is: test@mydomainname.com <test@mail.malhostdomain.com>

This does not happen when sent to gmail, outlook.com, yahoo or any other mailenable servers. In the logs the sender is correct email address, test@mydomainname.com,

The only thing in common is that the recipient is in a medical environment with supposedly increased security on email.

We have deleted the domain/postoffice in question and recreated it and the same problem persists.

We are using Mailenable 9.1 Enterprise.

Any idea why the this happening?

MailEnable-Ian
Site Admin
Posts: 9321
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: issue with sender and reply to email address being changed

Post by MailEnable-Ian » Thu Dec 03, 2020 10:52 pm

Hi,

Have you inspected the SMTP activity and debug log files for the outbound message being sent to see if the sender address in the SMTP conversation is correct? Perhaps the receiving server is changing the address.
Regards,

Ian Margarone
MailEnable Support

robertmac
Posts: 12
Joined: Fri Jan 09, 2009 7:45 pm

Re: issue with sender and reply to email address being changed

Post by robertmac » Fri Dec 04, 2020 12:09 am

Hi,

Yes everything in the logs has the correct sender. It is the receiving servers that are changing the sender address.

Did not believe it until we saw the headers and did tests from our own PCs.

It only happens with their domain/postoffice. Other domains on the sane server get delivered without the sender domain name getting replaced.

We verified all post office settings and compared them with a domain that was working and all the settings were the same.

Moved the postoffice over to another server with mailenable 10 and problem did not occur.

What could cause receive server to swap our sender domain name with the originating server host name?

Regards,
Robert

MailEnable-Ian
Site Admin
Posts: 9321
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: issue with sender and reply to email address being changed

Post by MailEnable-Ian » Fri Dec 04, 2020 1:50 am

Hi,

Unfortunately we cant answer that question. You will need to contact the administrators of the remote mail server to inspect their log files for more clues.
Regards,

Ian Margarone
MailEnable Support

Post Reply