[SOLVED]Please help! Spam By-Passed my custom global filter

Raise/discuss any potential issues with MailEnable for consideration in project issue register.
Post Reply
poweredge
Posts: 97
Joined: Sat May 29, 2021 11:16 am

[SOLVED]Please help! Spam By-Passed my custom global filter

Post by poweredge » Tue Jun 22, 2021 2:57 pm

This is the email header

X-PTR-Result: Generic, Fail
X-ME-Bayesian: 0.99500
X-ME-Spam: High (1050) <This is the final score calculated by ME anti-spam weighting system, which includes the SpamAssassin result as well.

The issue is that my customized filter "X-ME-Spam High" never got executed, only the default ME's score system filter is triggered, which add the header X-ME-Spam: High (1050)

06/22/21 14:47:25 Executed C641BDEF8B754EBC9A1ACCD7F7798DE3.MAI SMTP [System Spam Filter] ADD_HEADER [SMTP:newhopeglassmirror[at]domain.com] 123.235.203.28 High (1050) Lowest shipping costs

I wonder could it be a bug?
3.jpg
3.jpg (74.17 KiB) Viewed 1426 times
"X-ME-Spam High" is to be executed when header contains "*X-ME-Spam: High*" and also add the prefix [SPAM]

In fact, I noticed some spam email got executed with this filter, and most of the time, it got ignored.
Last edited by poweredge on Thu Jun 24, 2021 8:12 am, edited 1 time in total.

MailEnable-Ian
Site Admin
Posts: 9481
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Please help! Spam By-Passed my custom global filter

Post by MailEnable-Ian » Thu Jun 24, 2021 2:40 am

Hi,

The spam scores get added last after all the global filters are executed. Try and create your filter to trigger on the spam score header at the postoffice level and not at the global level.
Regards,

Ian Margarone
MailEnable Support

poweredge
Posts: 97
Joined: Sat May 29, 2021 11:16 am

Re: Please help! Spam By-Passed my custom global filter

Post by poweredge » Thu Jun 24, 2021 8:11 am

Thanks Ian, that explained why the feature of User Spam Protection Level in Webmail.

But most of the time, users do not login to webmail to set it, so I guess your suggestion of setting this filter at the postoffice level will solve the problem.

Btw, how come some of the High Score ones got filtered somehow? I thought it's either all or nothing.

Many thanks again!

Post Reply