Illegal PostOffice Name

Discussion regarding the Standard version.
Post Reply
willip
Posts: 4
Joined: Thu Dec 18, 2014 1:34 am

Illegal PostOffice Name

Post by willip » Mon Dec 02, 2019 2:22 pm

First install of mailEnable standard. Created postoffice called BMG during install. When I click on the postoffice in the management console and click anything else (create mailbox, etc). I get a popup "Illegal Postoff Name - Postoffice name not allowed: Post Offices"

Admin
Site Admin
Posts: 826
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Re: Illegal PostOffice Name

Post by Admin » Tue Dec 03, 2019 1:00 am

Hi,

The message is shown if the postoffice name has a space in it. It must be that it is allowing this in the install program. If you have just installed and there are no other postoffices and no data, it is easiest to just delete the contents of the Mail Enable\Config and Mail Enable\Postoffices directories and reinstall. Otherwise to fix you will need to edit the .TAB files in the Mail Enable\Config directory by opening in Notepad, and make sure that "BMG" text in those config files do not have any spaces around them. Tabs are ok, since they will separate the fields in the config files, but there should not be a space around the text. The postoffice directory under the Mail Enable\Postoffices path should be ok though.

willip
Posts: 4
Joined: Thu Dec 18, 2014 1:34 am

Re: Illegal PostOffice Name

Post by willip » Tue Dec 03, 2019 1:21 am

Odd, I didnt enter any spaces in the names, even tried deleting and creating with a differnt name, Same problem. Unistalled and installed the Pro trial version and all worked fine.

willip
Posts: 4
Joined: Thu Dec 18, 2014 1:34 am

Re: Illegal PostOffice Name

Post by willip » Tue Dec 03, 2019 1:23 am

Oh, and thanks. So far I've configured one domain/post office and it looks like mailenable will work for our situation.

Trekkie
Posts: 5
Joined: Wed Dec 11, 2019 10:24 pm

Re: Illegal PostOffice Name

Post by Trekkie » Wed Dec 11, 2019 10:34 pm

I just downloaded and installed version 10.28 onto our Windows Server 2019 Essentials and I keep getting the same error. I've even tried to uninstall (but that fails.)

I've done as suggest above and removed files, started over and even confirmed that the .tab files are correct.
Attachments
Illegal PO.png
Illegal PO.png (3.45 KiB) Viewed 13910 times

Trekkie
Posts: 5
Joined: Wed Dec 11, 2019 10:24 pm

Re: Illegal PostOffice Name

Post by Trekkie » Wed Dec 11, 2019 10:50 pm

I just installed 10.28 onto my Windows Server 2019 Essentials system and getting the same error.
Illegal PO.png
Illegal PO.png (3.45 KiB) Viewed 13910 times
I've done as suggested above and keep getting the same results. The uninstaller isn't working, but I'm also trying to use previous builds. When I tested this on a test machine a few months ago, it worked perfectly, but this version just won't let me and now I think I have some setting somewhere that's stopping me from doing it on older versions.

Trekkie
Posts: 5
Joined: Wed Dec 11, 2019 10:24 pm

Re: Illegal PostOffice Name

Post by Trekkie » Sun Dec 15, 2019 5:38 pm

Sorry for posting twice. I wasn't sure that my original message posted.

I found the instructions to remove the software, rebooted and reinstalled and it came up with the same error.

Does anyone have any suggestions?

Admin
Site Admin
Posts: 826
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Re: Illegal PostOffice Name

Post by Admin » Sun Jan 05, 2020 11:17 pm

Open the POSTOFFICE.TAB file in the Mail Enable\Config directory in Notepad. The error still indicates there is a space character in a postoffice name. Check through the file to see if any of the names have a problem. Otherwise please send it to our "sales at mailenable.com" email address and they can raise a support ticket for you, thanks.

Trekkie
Posts: 5
Joined: Wed Dec 11, 2019 10:24 pm

Re: Illegal PostOffice Name

Post by Trekkie » Mon Jan 13, 2020 5:43 pm

Thanks for the reply. I also just tried version 10.29 and got the same error.

I did just e-mail that address and hope to hear back. If I read the error message right, it might not even be my post office name (I've tried several versions, including just "Home"), but nothing takes. I'm starting to think the error in the message might be literal - there is a space in "Post Offices" in some setting somewhere.

Trekkie
Posts: 5
Joined: Wed Dec 11, 2019 10:24 pm

Re: Illegal PostOffice Name

Post by Trekkie » Tue Jan 14, 2020 4:24 pm

For those of you that run into the same issue, it looks like it's an issue with how the MMC for MailEnable is created during setup. The MailEnable snap-in is 32 bit and the MMC must be setup using the /32 parameter.

Please reference https://www.mailenable.com/kb/content/article.asp?ID=ME020274

Post Reply