Cannot send email to external domain

Discussion regarding the Standard version.
Post Reply
Oblit3ration
Posts: 3
Joined: Mon Oct 13, 2008 4:12 pm

Cannot send email to external domain

Post by Oblit3ration » Mon Oct 13, 2008 4:20 pm

Hi all,

I've had a go at installed MailEnable on my server, I've registered a couple of domain names, and configured (as far as I'm aware!) MailEnable for the domain's to send and recieve email.

I've pointed the MX and A record on my domain registration page to my servers external IP, setup the mailboxes and domains within MailEnable, configured an Outlook client on a totally seperate machine on a different network.

I can receive email sent from external domains (my work address, my friends addresses etc etc) and they all get received fine, however I cannot reply to them.

I can see all the email sitting in the outbound queue on the SMTP queue on MailEnable, and I get a load of 'Delivery delayed' emails arriving in my email client.

The errors on the outbound SMTP queue mention:

"The socket connection to the remote host failed. The host was wither not contactable or it rejected your connection"

I'm really confuzzled as to what to try and do next, this is happening with all domains I attempt to send to where I can vouch that they are not offline!

Any advice / thoughts / help very very much appreciated.

Thanks all,

dreniarb
Posts: 316
Joined: Mon Jan 19, 2004 5:00 pm
Location: Marion, IN

Post by dreniarb » Mon Oct 13, 2008 7:01 pm

Seems like either your ISP or perhaps your router is blocking outgoing port 25?

If that's the case, contact your ISP, or redirect all your outgoing mail to a server that listens on an alternate port.

Oblit3ration
Posts: 3
Joined: Mon Oct 13, 2008 4:12 pm

Post by Oblit3ration » Mon Oct 13, 2008 7:05 pm

Thanks Dreniarb, I have tested a telnet to a friendly Exchange server on port 25 and that goes through no problem, I was wondering if it is something in my MailEnable setup that I've stupidly missed, but having done a DNSSTUFF reverse DNS check it appears there is no PTR set:

[From DNSstuff.com]

Answer:
No PTR records exist for **.**.**.**. [Neg TTL=3600 seconds]

I'm using EuroVPS for my hosting, and I have absolutely no idea where I would get this added!

Time for some more research me thinks!

dreniarb
Posts: 316
Joined: Mon Jan 19, 2004 5:00 pm
Location: Marion, IN

Post by dreniarb » Mon Oct 13, 2008 7:18 pm

What does your smtp-debug log show when it attempts to send the message? Is it able to get the mx listing for the domain name? Any evidence of it connecting to that server.

Here's a bit from mine for an email that sitting in my outbound queue with the same error you're showing:

Code: Select all

10/13/08 10:28:01	ME-I0123: Domain [aynrandlexicon.com] has MX list [vemail.forethought.net,vemail2.forethought.net]
10/13/08 10:28:01	ME-I0026: [AB814E8877E04A7A8DE9F607F271E992.MAI] Sending message
10/13/08 10:28:05	ME-IXXXX: [AB814E8877E04A7A8DE9F607F271E992.MAI] Remote server returned a response indicating a temporary failure. Server Response: (451 Temporary local problem - please try later**)
10/13/08 10:28:05	ME-E0034: [AB814E8877E04A7A8DE9F607F271E992.MAI] RCPT command to all recipients produced an error.
10/13/08 10:28:05	ME-I0050: [AB814E8877E04A7A8DE9F607F271E992.MAI] Send attempt completed successfully, but some recipients did not resolve
10/13/08 10:28:05	ME-I0053: [AB814E8877E04A7A8DE9F607F271E992.MAI] Message generated a recipient failure message to sender.
10/13/08 10:28:05	ME-I0054: [AB814E8877E04A7A8DE9F607F271E992.MAI] Message is being requeued to recipients where server returned an error.
And here's the server talk from the smtp-activity log:

Code: Select all

10/13/08 11:28:02	SMTP-OU	AB814E8877E04A7A8DE9F607F271E992.MAI	1164	216.241.36.26	CONN		220 mz2.forethought.net ESMTP Exim 4.69 Mon, 13 Oct 2008 09:27:56 -0600	0	73		Delivery Failure
10/13/08 11:28:02	SMTP-OU	AB814E8877E04A7A8DE9F607F271E992.MAI	1164	216.241.36.26	EHLO	EHLO dreniarbsserver.com	250-mz2.forethought.net Hello mail.dreniarbsserver.com [24.123.1.34]	21	147		Delivery Failure
10/13/08 11:28:02	SMTP-OU	AB814E8877E04A7A8DE9F607F271E992.MAI	1164	216.241.36.26	MAIL	MAIL FROM:<POSTMASTER@dreniarbsserver.com> SIZE=651	250 OK	48	8		Delivery Failure
10/13/08 11:28:05	SMTP-OU	AB814E8877E04A7A8DE9F607F271E992.MAI	1164	216.241.36.26	RCPT	RCPT TO:<CaseyasynchronousJennings@aynrandlexicon.com>	451 Temporary local problem - please try later	56	48		Delivery Failure
Maybe it's nothing on your end?

Oblit3ration
Posts: 3
Joined: Mon Oct 13, 2008 4:12 pm

Post by Oblit3ration » Wed Oct 15, 2008 8:51 am

Thanks Dreniarb,

It appears some muppet (namely me!) forgot to get the PTR record set for the domain! All mail (well, my test eamils) were getting rejected because of this. Once it was set mail flowed correctly.

Appreciate you taking the time to help me :)

Post Reply