Big Delay in message sending

Discussion regarding the Standard version.
Post Reply
NEOBOY
Posts: 47
Joined: Thu Jul 18, 2002 5:29 pm

Big Delay in message sending

Post by NEOBOY » Thu Aug 15, 2002 6:19 pm

Hello, since I placed 3rd party (domain.com --> sitemail.everyone.net as smarthost) it has been a great damper to ME because when I would try to send mail from local domains that is ran by ME...it would take about a day to receive from the other end.

Please help!

totomds
Posts: 24
Joined: Thu Aug 08, 2002 11:22 am

Post by totomds » Thu Aug 15, 2002 8:05 pm

Neoboy,

I'm not sure I understood your situation, could you please explain it a little more? From what I understand a small fix for your situation would be to go to MailEnable and follow these steps:

1. Go to Servers > LocalHost > Connectors
2. Right click on SMTP
3. Click on Advanced SMTP
4. Change the "Message Retry Interval" to a lower number.

This is a small fix which should help until you can explain your situation better.

-toto

NEOBOY
Posts: 47
Joined: Thu Jul 18, 2002 5:29 pm

Thanks!

Post by NEOBOY » Fri Aug 16, 2002 5:09 am

totomds! Thanks for your help, I think that would definitely solve the problem.

NEOBOY
Posts: 47
Joined: Thu Jul 18, 2002 5:29 pm

Another Question

Post by NEOBOY » Fri Aug 16, 2002 6:24 am

I have another question:

How do I setup an 3rd party server on IIS 5? Because I have a client who is using everyone.net(sitemail.everyone.net) as their mail client. Though I don't want to use Mail Enable to use it as a smarthost. It seems to bogged the ME STMP client down.

Is there another way such as in the MMC?

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Fri Aug 16, 2002 6:55 am

There is no current means of configuring IIS to function as a full Mail server. (But you can install and configure multiple mail servers to run on the same machine - not advisable though.) - suspect the problem may be elsewhere.

You would have to be relaying quite a bunch of mail through the server for smarthosting to block the outbound message queues to the degree where messages from local domains are being delayed by a day - Smarthosting should not bog down the server. In actual fact, the server should be doing less work. The only time consuming aspects aspects associated with smarthosting is a potential DNS lookup. This scalability article pretty much points out where ME's bottlenecks are:
http://www.mailenable.com/support/MailE ... 01-0-2.pdf.

Important:- Make sure you turn FASTFIND off (use the control panel) on any volumes that contain queues and pstoffice data

If you are moving large REALLY large quantities of messages via SMTP (ie: more than 3 messages per second wither inbound or outbound), then you may want to consider applying this hotfix as it has significant performance improvements in Windows 2000). http://www.mailenable.com/hotfix/ (SMTP Connector - 10th August) - this will be supplied in the next release of ME in any case.

If you are not moving large quantities of messages, you may be experiencing a lack of responsiveness from your DNS Server.

Let me know:
1..If I have understood your predicament
2.. How much mail your moving through the SMTP connectors (size of queues inbound and outbound will give an indication of where it is busy)

You may also want to run the Windows Task Manager or Performance Montor to determine what is limiting mail throughput. See if the SMTP Connector is using CPU - It is called MESMTPC.EXE.

Hope this helps,

Dave
Regards, Andrew

NEOBOY
Posts: 47
Joined: Thu Jul 18, 2002 5:29 pm

Fastfind

Post by NEOBOY » Fri Aug 16, 2002 7:20 am

Important:- Make sure you turn FASTFIND off (use the control panel) on any volumes that contain queues and pstoffice data
How do you turn fastfind off?

NEOBOY
Posts: 47
Joined: Thu Jul 18, 2002 5:29 pm

worked but not really...

Post by NEOBOY » Fri Aug 16, 2002 7:43 am

I've deleted the domain that uses the 3rd party (sitemail.everyone.net) but here's the problem. I am able to send mail to anyone in the whole world but not receive any from anyone.

Thanks for helping guys :wink:

NEOBOY
Posts: 47
Joined: Thu Jul 18, 2002 5:29 pm

Re: worked but not really...

Post by NEOBOY » Fri Aug 16, 2002 11:58 am

NEOBOY wrote:I've deleted the domain that uses the 3rd party (sitemail.everyone.net) but here's the problem. I am able to send mail to anyone in the whole world but not receive any from anyone.

Thanks for helping guys :wink:
Got everything fixed so no need to give me any tech-support on my problems. :D

ChrisHenry

Disabling FastFind

Post by ChrisHenry » Mon May 12, 2003 5:17 pm

To disable fast find, as referenced above, right-click on the folder or volume in question and choose properties.

On a volume, there's a check-box at the bottom "Allow Indexing Service to index this disk for fast searching". Un-check that box. You'll be prompted to do it for the whole drive or just the root directory. You'll want to do it for the whole drive, probably.

Alternately, you can just do this to a folder. Right-Click the folder, choose properties, then click the Advanced button on the General tab. In the advanced box, uncheck "For Fast searching..."

Cheers,
Chris.

Post Reply