"Misconfigured Sender" appears in email header

Discussion regarding the Standard version.
Post Reply
apritcha
Posts: 7
Joined: Wed Feb 11, 2004 6:13 am

"Misconfigured Sender" appears in email header

Post by apritcha » Mon Mar 15, 2004 4:01 am

Hi,

I've had ME Standard for a while now and haven't had too many problems. Something has come up that I've just noticed though. When I send myself some test emails (i.e. email from my ME server to another email account that I have with Comcast) and look at the headers after the email has arrived, it says "Misconfigured Sender" next to my server name and IP address. It's not a huge problem, but I see a lot of spam that also says that... and I don't want email from my server to resemble spam.

Does anyone know what is likely to be misconfigured?

Thanks in advance!
Andrew

apritcha
Posts: 7
Joined: Wed Feb 11, 2004 6:13 am

Post by apritcha » Fri Mar 19, 2004 5:04 pm

14 views and still no answer...

Anyone have any ideas?

Cheers,
Andrew

MDColson
Posts: 109
Joined: Sat Aug 23, 2003 8:29 pm

Post by MDColson » Fri Mar 19, 2004 5:13 pm

post the header... i'm pretty sure thats something that comcast's mailservers appends to the headers. i'm assuming that you're smarthosting through their server? correct? post the header and i'll take a look!

mdcolson

luptona
Posts: 67
Joined: Mon Jul 07, 2003 3:18 pm
Location: Dallas, TX, USA
Contact:

Post by luptona » Fri Mar 19, 2004 6:57 pm

I'm getting the same. I have my mail server configured at x.x.x.203 but receiving servers see it at x.x.x.200 which is the primary server IP. This causes a reverse PTR failure as .200 reports a different name than .203 (mail). Many servers reject the mail because of this.
Where can I check this to ensure that my ME server is only sending out mail on the proper IP?

AlertServ
Posts: 30
Joined: Fri Oct 03, 2003 1:36 am
Contact:

Post by AlertServ » Sat Mar 20, 2004 10:37 pm

luptona wrote:Where can I check this to ensure that my ME server is only sending out mail on the proper IP?
Open the MailEnable MMC and go to the properties of the SMTP Connection. Click the outbound binding and change he IP. Stop and start the SMTP service.
Alert Serv | Managed Windows Servers, Incident Support
Including Support for Mail Enable & Helm - http://www.AlertServ.com
------------------------------------------------------
Authorized Helm Reseller

apritcha
Posts: 7
Joined: Wed Feb 11, 2004 6:13 am

Post by apritcha » Mon Mar 22, 2004 6:22 pm

Hi,

Here is the header (domain name and IP altered):
Received: from mydomain.com (ns1.mydomain.com[xxx.xxx.xxx.xxx](misconfigured sender))

by rwcrmxc14.comcast.net (rwcrmxc14) with ESMTP

id <20040319173705r1400h2p1ke>; Fri, 19 Mar 2004 17:37:05 +0000

X-Originating-IP: [xxx.xxx.xxx.xxx]

Received: from mycomputer ([xxx.xxx.xxx.xxx]) by mydomain.com with MailEnable ESMTP; Fri, 19 Mar 2004 12:37:03 -0500

From: "Me" <user@mydomain.com>

To: "Me" <user@comcast.net>

Subject: Testing

Date: Fri, 19 Mar 2004 12:45:51 -0500

MIME-Version: 1.0

Content-Type: multipart/alternative;

boundary="----=_NextPart_000_002E_01C40DB0.1CD89E20"

X-Mailer: Microsoft Office Outlook, Build 11.0.5510

Thread-Index: AcQN2gU6zXEeQo6pQT2sMymxpOqCdg==

X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
I hope it can shed some light.

I'm hosting it on my own server with Windows Server 2003 installed, not through Comcast's servers.

Thanks for your help,
Andrew

MDColson
Posts: 109
Joined: Sat Aug 23, 2003 8:29 pm

Post by MDColson » Mon Mar 22, 2004 7:29 pm

you're defintaely smarthosting through comcasts mailservers. it shows that in your header.

Received: from mydomain.com (ns1.mydomain.com[xxx.xxx.xxx.xxx](misconfigured sender))
by rwcrmxc14.comcast.net (rwcrmxc14) with ESMTP

this means that your server (ns1.mydomain.com) is passing email to rwcrmxc14.comcast.net... the misconfigured sender is being put there by the comcast server. nothing you can do about it!

MDColson

apritcha
Posts: 7
Joined: Wed Feb 11, 2004 6:13 am

Post by apritcha » Mon Mar 22, 2004 8:08 pm

Hi,

Thanks for the speedy replies.

I didn't think I was Smart Hosting. I have not enabled Smart Hosting in MailEnable, and my server is leased from ValueWeb so it's not as though Comcast provides the Internet connection for my server. How would I be Smart Hosting through them?

I thought that headers like that were automatically added. The only reason Comcast's information appears there is because the email is being sent to a Comcast address, so the message has to be passed off to a Comcast server at some point.

As an example, here's an email sent to a different domain:
Received: from mydomain.com [xxx.xxx.xxx.xxx] by mail019.readyhosting.com with ESMTP
(SMTPD32-7.14) id A7261FC800FA; Mon, 22 Mar 2004 14:05:58 -0600
Received: from mycomputer ([xxx.xxx.xxx.xxx]) by mydomain.com with MailEnable ESMTP; Mon, 22 Mar 2004 14:57:33 -0500
From: "Me" <user@mydomain.com>
To: <user@someotherdomain.com>
Subject: Test
Date: Mon, 22 Mar 2004 15:06:21 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0037_01C4101F.3CDAA850"
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
Thread-Index: AcQQSSUf+q+jGxKxSnOSS+6akiIZoQ==
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-Id: <200403221406187.SM02448@mydomain.com>
X-RCPT-TO: <user@someotherdomain.com>
Status: U
X-UIDL: 349226049
Again, the email is passed to another server, but only because that server handles email for the addressee's domain.

I guess I was just wondering if there was something specific that Comcast checked for in determining a server's configuration that I may have overlooked. Or is there still nothing I can do about it?

Thanks again!
Andrew

luptona
Posts: 67
Joined: Mon Jul 07, 2003 3:18 pm
Location: Dallas, TX, USA
Contact:

Post by luptona » Fri Mar 26, 2004 3:22 pm

AlertServ wrote:
luptona wrote:Where can I check this to ensure that my ME server is only sending out mail on the proper IP?
Open the MailEnable MMC and go to the properties of the SMTP Connection. Click the outbound binding and change he IP. Stop and start the SMTP service.
Thanks! I changed that and the issue cleared (I was seeing the Comcast misconfigured error too); now however, it seems some of my local programs (such as my Helm control panel and my PHPBB forum) are unable to send outbound mail as the server is outbound on the mail server IP and helm is bound to a different IP. I would have thought that the "in" binding to local IPs controlled this but it seems that the outbinding is interfering.. any thoughts?

Post Reply