Completely blank emails getting through

Discussion regarding the Standard version.
Post Reply
sgs
Posts: 2
Joined: Mon May 09, 2016 10:13 am

Completely blank emails getting through

Post by sgs » Mon May 09, 2016 10:53 am

Hi

I'm running Version 9.10 Standard.
Over the last few days I've starting receiving completely blank emails, no FROM, no TT, No SUBJECT and no BODY
When I look in the SMTP-Activity log I can see MAIL FROM: has a "%" wildcard as the domain for these blank emails.
e.g. MAIL FROM <VENTAS@%> 250 Requested mail action okay, completed 43 23 (VENTAS is different for each message)
Obviously they're spam but I can't find a way to reject them.

I have tried modifying the SMTP-Inbound.vbs script but I'm not sure the standard version can execute scripts. I have searched but can't find a definitive answer.

Would really appreciate any pointers in getting the "MAIL FROM %" rejected or helping me execute the script.

Thanks

Sam

MailEnable-Ian
Site Admin
Posts: 8976
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Completely blank emails getting through

Post by MailEnable-Ian » Tue May 10, 2016 3:25 am

Hi,

The SMTP security option to "Reject mail if sender address is from invalid domain" should block the % in the domain portion of the mail from address since it is not a valid domain. I was able to emulate locally and raised an issue. It has been fixed for the next minor release.
Regards,

Ian Margarone
MailEnable Support

sgs
Posts: 2
Joined: Mon May 09, 2016 10:13 am

Re: Completely blank emails getting through

Post by sgs » Tue May 10, 2016 7:58 am

Hi Ian

Thank for the reply, that's great. I can stop pulling my hair out now.

Sam :D

kiamori
Posts: 223
Joined: Wed Nov 04, 2009 1:39 am
Contact:

Re: Completely blank emails getting through

Post by kiamori » Sun Oct 07, 2018 6:46 pm

This seems to be an issue again with version 10 but the option to "Reject mail if sender address is from invalid domain" is no longer in the SMTP security tab.

MailEnable-Ian
Site Admin
Posts: 8976
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Completely blank emails getting through

Post by MailEnable-Ian » Sun Oct 07, 2018 11:33 pm

Hi,

The option "Reject mail if sender address is from invalid domain" is now named "Sender email domain must be local or resolvable through DNS".

http://www.mailenable.com/documentation ... urity.html
Regards,

Ian Margarone
MailEnable Support

scree74
Posts: 16
Joined: Fri Aug 22, 2014 10:16 am

Re: Completely blank emails getting through

Post by scree74 » Tue May 28, 2019 8:58 am

Hi Ian

I have the same issue but the option for “sender email domain must be local or resolvable through dns is selected I am using version 10.20 enterprise can you advise.

Many thanks in advance
Scott

Post Reply