Mail forwarding to Gmail relay does not work

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Sat Dec 16, 2017 8:44 pm

Ive configured my copy of Mail Enable standard 10.11 to attempt to send mail to gmail on a relay without any success. Im using the following:
SMTP Props:
Outbound:
Outbound TLS

Relay:
Authentication (using a valid email account)

Smart Host
IP/domain: smtp.gmail.com
port: 587
account: valid email account and password

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 12:12 am

Hi,

If you are simply trying to relay messages to a Gmail recipient address then there is no need to smarthost. Therefore disable the SMTP smarthost as it is not needed. Gmail does not enforce TLS therefore to test disable outbound TLS and inbound TLS and then try to send to gmail from your email client. If that does not work then post up the log snippet from within the SMTP activity an debug log files so we can see what is happening when the message is relayed to the Gmail server.
Regards,

Ian Margarone
MailEnable Support

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 12:52 am

That's just it..... I'm trying to set up a ticketing system that could, in theory, send to anyone.

The system os OS Ticket. It uses PHPMail for its underlying system for sending out emails. What this system does is to send out emails when I set up new accounts or to send a copy of the ticket to the recipient.

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 2:13 am

Hi,

Have you checked the MailEnable SMTP log files at the time of your tests to see what is happening when it fails to send.
Regards,

Ian Margarone
MailEnable Support

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 3:06 am

Of course...

Apparently nothing. I can try again and attach the SMTP logs.

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 3:19 am

Just so I have it configured correctly, could you list all the settings screen by screen that need to be in place to actually get this working? Some of the settings seem redundant.

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 3:19 am

Hi,

If there is no evidence of a connection from your PHP mailer in the SMTP log files then the problem will be the PHP script. If you try to configure an email client (I.e.: Outlook), are you able to send?
Regards,

Ian Margarone
MailEnable Support

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 3:39 am

Ian,... I havent been able to even get that far... Ive been only been testing with telnet so far. and I get no indication that the message is being queued for delivery or whatever.

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 3:50 am

Hi,

How are you testing with telnet? Are you authenticating via telnet to be granted relay rights to send to gmail? If you are connecting from are remote location and don't authenticate you wont be able to relay. try and login to the web mail client locally on the server via http://mewebmail.localhost or http://localhost/mewebmail. Login using a mailbox you created in MailEnable and then send to the Gmail account to see if its able to send outbound. This will at least give you an indication if you are able to send via MailEnable to a n external address.
Regards,

Ian Margarone
MailEnable Support

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 4:05 am

Im using PUTTY and connecting on port 587 to the local host

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 4:16 am

Hi,

Are you authenticating when you issue the SMTP commands via telnet? Can you post up a screenshot of the telnet session? When you check the SMTP log files for the inbound connection when you are telnetting what is reported in the SMTP log files?
Regards,

Ian Margarone
MailEnable Support

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 4:23 am

for grins and giggles, I stopped the ME services and started up the Microsoft SMTP IIS 6 service and sent an email the same way, its stuck in an outgoing state for over 255 seconds. Now I'll send those screenshots in the next post.

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 4:27 am

Hi,

Do you see the inbound connection in the MailEnable SMTP log files? If not then its not connecting at all and this maybe a firewall problem.
Regards,

Ian Margarone
MailEnable Support

jschultz0614
Posts: 16
Joined: Thu Dec 04, 2014 4:56 pm

Re: Mail forwarding to Gmail relay does not work

Postby jschultz0614 » Mon Dec 18, 2017 4:59 am

-------------------------------------------------------------------------------------------------------------------------------------------
Here are the log files and the screenshot you requested. Actually, here is the output from putty (I don't have a place to put up a image ATM)
-------------------------------------------------------------------------------------------------------------------------------------------
220 S132-148-81-176.secureserver.net ESMTP MailEnable Service, Version: 10.11-- ready at 12/17/17 21:37:30
HELO 127.0.0.1
503 Bad sequence of commands
EHLO 127.0.0.1
250-secureserver.net [127.0.0.1], this server offers 5 extensions
250-AUTH LOGIN
250-SIZE 40960000
250-HELP
250-AUTH=LOGIN
250 STARTTLS
AUTH LOGIN
334 VXNlcm5hbWU6
**********
334 UGFzc3dvcmQ6
**********
535 Invalid Username or Password
AUTH LOGIN
334 VXNlcm5hbWU6
**********
334 UGFzc3dvcmQ6
**********
235 Authenticated
MAIL FROM:john@johneschultz0614@gmail.com
250 Requested mail action okay, completed
RCPT TO:jschultz0614@gmail.com
250 Requested mail action okay, completed
Test Message
503 Bad sequence of commands
.
503 Bad sequence of commands
DATA
354 Start mail input; end with <CRLF>.<CRLF>
Test Message

.
250 Requested mail action okay, completed



-------------------------------------------------------------------------------------------------------------------------------------------
Last part of the Activity log
-------------------------------------------------------------------------------------------------------------------------------------------
12/17/17 21:29:02 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 220 S132-148-81-176.secureserver.net ESMTP MailEnable Service, Version: 10.11-- ready at 12/17/17 21:29:02 0 0
12/17/17 21:29:14 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 UNKN ÿûÿû ÿûÿû'ÿýÿûÿýHELO 127.0.0.1 503 Bad sequence of commands 30 37
12/17/17 21:29:24 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 EHLO EHLO 127.0.0.1 250-secureserver.net [127.0.0.1], this server offers 5 extensions 142 16
12/17/17 21:29:49 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 AUTH AUTH LOGIN:jschultz0614@gmail.com 504 Unrecognized authentication type. 39 35
12/17/17 21:30:00 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 UNKN AUTO LOGIN 503 Bad sequence of commands 30 12
12/17/17 21:30:07 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 AUTH AUTH LOGIN 334 VXNlcm5hbWU6 18 12
12/17/17 21:30:31 SMTP-IN 701ACE3E041F48FE8D62731B285D8012.MAI 820 127.0.0.1 AUTH 501 Error decoding Username parameter. 40 2
12/17/17 21:37:30 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 220 S132-148-81-176.secureserver.net ESMTP MailEnable Service, Version: 10.11-- ready at 12/17/17 21:37:30 0 0
12/17/17 21:37:39 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 UNKN ÿûÿû ÿûÿû'ÿýÿûÿýHELO 127.0.0.1 503 Bad sequence of commands 30 37
12/17/17 21:37:50 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 EHLO EHLO 127.0.0.1 250-secureserver.net [127.0.0.1], this server offers 5 extensions 142 16
12/17/17 21:37:58 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 AUTH AUTH LOGIN 334 VXNlcm5hbWU6 18 12
12/17/17 21:38:00 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 AUTH {blank} 334 UGFzc3dvcmQ6 18 10 john
12/17/17 21:38:27 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 AUTH ****** 535 Invalid Username or Password 34 18 john
12/17/17 21:39:26 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 AUTH AUTH LOGIN 334 VXNlcm5hbWU6 18 12 john
12/17/17 21:39:27 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 AUTH {blank} 334 UGFzc3dvcmQ6 18 30 john@johneschultz.com
12/17/17 21:39:47 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 AUTH {blank} 235 Authenticated 19 18 john@johneschultz.com
12/17/17 21:40:22 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 MAIL MAIL FROM:john@johneschultz0614@gmail.com 250 Requested mail action okay, completed 43 43 john@johneschultz.com
12/17/17 21:40:39 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 RCPT RCPT TO:jschultz0614@gmail.com 250 Requested mail action okay, completed 43 32 john@johneschultz.com
12/17/17 21:40:46 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 UNKN Test Message 503 Bad sequence of commands 30 14 john@johneschultz.com
12/17/17 21:40:47 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 UNKN . 503 Bad sequence of commands 30 3 john@johneschultz.com
12/17/17 21:40:56 SMTP-IN 7CC3FC04326D45E8A708038AAEC7BDDC.MAI 860 127.0.0.1 DATA DATA 354 Start mail input; end with <CRLF>.<CRLF> 46 6 john@johneschultz.com


-------------------------------------------------------------------------------------------------------------------------------------------
Last session of the Debug log
-------------------------------------------------------------------------------------------------------------------------------------------
12/17/17 21:28:33 ME-I0143: Service Loading Configuration Providers
12/17/17 21:28:33 ME-IXXXX: Loaded Address Map Provider
12/17/17 21:28:33 ME-IXXXX: Loaded Authentication Provider
12/17/17 21:28:33 ME-IXXXX: Loaded MEAISM Configuration Provider
12/17/17 21:28:33 ME-IXXXX: Loaded MEAIDP Directory Provider
12/17/17 21:28:33 ME-IXXXX: Loaded MEAILS Configuration Provider
12/17/17 21:28:33 ME-IXXXX: Loaded Postoffice Configuration Provider
12/17/17 21:28:33 ME-I0073: MEW2KDNS Initialized to use DNS Servers (208.109.96.2)
12/17/17 21:28:33 ME-IXXXX: No plug-in DLL configured
12/17/17 21:28:33 ME-I0141: Service Starting
12/17/17 21:28:33 ME-I0139: Outbound Mail Agent Initialised
12/17/17 21:28:33 ME-I0139: Initializing DomainKeys Extension
12/17/17 21:28:33 ME-I0140: Standard Inbound Mail Agent Initialised
12/17/17 21:28:33 ME-I0082: Service binding to all addresses on port (25) for IPv4 family (2). Requires authentication 0
12/17/17 21:28:33 ME-I0085: Service (Alternate) binding to all IPv4 addresses on port (587). Requires authentication 1
12/17/17 21:28:33 ME-I0082: Service binding to all addresses on port (25) for IPv6 family (23).
12/17/17 21:28:33 ME-I0085: Service (Alternate) binding to all IPv6 addresses on port (587).
12/17/17 21:28:33 ME-I0144: Service Completed Loading Agents.
12/17/17 21:28:33 ME-I0065: [SYSTEM] Initalised Send Message Master Thread
12/17/17 21:28:33 ME-I0065: [SYSTEM] Resetting queued messages
12/17/17 21:28:33 ME-I0066: [SYSTEM] No outgoing message files in queue.
12/17/17 21:28:33 ME-IXXXX: Initalised Recv Message Master Thread
12/17/17 21:28:33 ME-I0076: Listening for connections on port 25 no SSL for IPv4
12/17/17 21:28:33 ME-IXXXX: Initalised Recv Message Master Thread
12/17/17 21:28:33 ME-I0076: Listening for connections on port 25 no SSL for IPv6
12/17/17 21:28:33 ME-IXXXX: Initalised Recv Message Master Thread
12/17/17 21:28:33 ME-I0076: Listening for connections on port 587 no SSL for IPv4
12/17/17 21:28:33 ME-IXXXX: Initalised Recv Message Master Thread
12/17/17 21:28:33 ME-I0076: Listening for connections on port 587 no SSL for IPv6
12/17/17 21:32:19 ME-I0070: (recv) socket [820] was gracefully closed during [AUTH] command by the remote client 127.0.0.1.
12/17/17 21:32:19 ME-I0074: [820] (Debug) End of conversation
12/17/17 21:38:27 ME-I0133: Authenticating User:john using Connector Credentials
12/17/17 21:39:47 ME-I0133: Authenticating User:****** using Connector Credentials
12/17/17 21:40:39 ME-I0107: [860] Relay Granted: Sender IP (127.0.0.1) is within an authorized IP range.
12/17/17 21:41:04 ME-I0149: [860] 7CC3FC04326D45E8A708038AAEC7BDDC.MAI was received successfully and delivery thread was initiated



-------------------------------------------------------------------------------------------------------------------------------------------
Last session of W3C Log
-------------------------------------------------------------------------------------------------------------------------------------------
#Software: MailEnable SMTP Server Version 1.0a
#Version: 1.0
#Date: 12/17/17 21:28:33
#Fields: date time c-ip agent account s-ip s-port cs-method cs-uristem cs-uriquery s-computername sc-bytes cs-bytes cs-username
2017-12-17 21:29:14 127.0.0.1 SMTP-IN - 127.0.0.1 820 UNKN ÿûÿû+ÿûÿû'ÿýÿûÿýHELO+127.0.0.1 503+Bad+sequence+of+commands S132-148-81-176 30 37 -
2017-12-17 21:29:24 127.0.0.1 SMTP-IN - 127.0.0.1 820 EHLO EHLO+127.0.0.1 250-secureserver.net+[127.0.0.1],+this+server+offers+5+extensions S132-148-81-176 142 16 -
2017-12-17 21:29:49 127.0.0.1 SMTP-IN - 127.0.0.1 820 AUTH AUTH+LOGIN:jschultz0614@gmail.com 504+Unrecognized+authentication+type. S132-148-81-176 39 35 -
2017-12-17 21:30:00 127.0.0.1 SMTP-IN - 127.0.0.1 820 UNKN AUTO+LOGIN 503+Bad+sequence+of+commands S132-148-81-176 30 12 -
2017-12-17 21:30:07 127.0.0.1 SMTP-IN - 127.0.0.1 820 AUTH AUTH+LOGIN 334+VXNlcm5hbWU6 S132-148-81-176 18 12 -
2017-12-17 21:30:31 127.0.0.1 SMTP-IN - 127.0.0.1 820 AUTH - 501+Error+decoding+Username+parameter. S132-148-81-176 40 2 -
2017-12-17 21:37:39 127.0.0.1 SMTP-IN - 127.0.0.1 860 UNKN ÿûÿû+ÿûÿû'ÿýÿûÿýHELO+127.0.0.1 503+Bad+sequence+of+commands S132-148-81-176 30 37 -
2017-12-17 21:37:50 127.0.0.1 SMTP-IN - 127.0.0.1 860 EHLO EHLO+127.0.0.1 250-secureserver.net+[127.0.0.1],+this+server+offers+5+extensions S132-148-81-176 142 16 -
2017-12-17 21:37:58 127.0.0.1 SMTP-IN - 127.0.0.1 860 AUTH AUTH+LOGIN 334+VXNlcm5hbWU6 S132-148-81-176 18 12 -
2017-12-17 21:38:00 127.0.0.1 SMTP-IN - 127.0.0.1 860 AUTH {blank} 334+UGFzc3dvcmQ6 S132-148-81-176 18 10 john
2017-12-17 21:38:27 127.0.0.1 SMTP-IN - 127.0.0.1 860 AUTH MTIkYzArIUBuRDM0 535+Invalid+Username+or+Password S132-148-81-176 34 18 john
2017-12-17 21:39:26 127.0.0.1 SMTP-IN - 127.0.0.1 860 AUTH AUTH+LOGIN 334+VXNlcm5hbWU6 S132-148-81-176 18 12 john
2017-12-17 21:39:27 127.0.0.1 SMTP-IN - 127.0.0.1 860 AUTH {blank} 334+UGFzc3dvcmQ6 S132-148-81-176 18 30 john@johneschultz.com
2017-12-17 21:39:47 127.0.0.1 SMTP-IN - 127.0.0.1 860 AUTH {blank} 235+Authenticated S132-148-81-176 19 18 john@johneschultz.com
2017-12-17 21:40:22 127.0.0.1 SMTP-IN - 127.0.0.1 860 MAIL MAIL+FROM:john@johneschultz0614@gmail.com 250+Requested+mail+action+okay,+completed S132-148-81-176 43 43 john@johneschultz.com
2017-12-17 21:40:39 127.0.0.1 SMTP-IN - 127.0.0.1 860 RCPT RCPT+TO:jschultz0614@gmail.com 250+Requested+mail+action+okay,+completed S132-148-81-176 43 32 john@johneschultz.com
2017-12-17 21:40:46 127.0.0.1 SMTP-IN - 127.0.0.1 860 UNKN Test+Message 503+Bad+sequence+of+commands S132-148-81-176 30 14 john@johneschultz.com
2017-12-17 21:40:47 127.0.0.1 SMTP-IN - 127.0.0.1 860 UNKN . 503+Bad+sequence+of+commands S132-148-81-176 30 3 john@johneschultz.com
2017-12-17 21:40:56 127.0.0.1 SMTP-IN - 127.0.0.1 860 DATA DATA 354+Start+mail+input;+end+with+<CRLF>.<CRLF> S132-148-81-176 46 6 john@johneschultz.com
2017-12-17 21:41:04 127.0.0.1 SMTP-IN - 127.0.0.1 860 DATA DATA 354+Start+mail+input;+end+with+<CRLF>.<CRLF> S132-148-81-176 43 19 john@johneschultz.com
Last edited by jschultz0614 on Mon Dec 18, 2017 5:13 am, edited 1 time in total.

MailEnable-Ian
Site Admin
Posts: 8714
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mail forwarding to Gmail relay does not work

Postby MailEnable-Ian » Mon Dec 18, 2017 5:08 am

Hi,

Did you issue a "QUIT" command after the "DATA" command as I cant see that in the logs you provided.
Regards,

Ian Margarone
MailEnable Support

Who is online

Users browsing this forum: No registered users and 8 guests