Whitelisting and Mail Component

Discussion regarding the Standard version.
Post Reply
Alyson_J
Posts: 40
Joined: Sat Jun 15, 2002 9:44 pm
Location: United Kingdom
Contact:

Whitelisting and Mail Component

Post by Alyson_J » Tue Nov 26, 2002 8:57 am

Hi

I've just upgraded to ME Standard and Pro versions 1.610 and 1.0014. I've turned on Reverse DNS Blacklisting as we were drowining in spam.

I've just noticed that now when some of my hosted domains which use the ME Mail component that of course this is now being refused as it comes from 127.0.1.

Any ideas how I can rectify this without making my server vulnerable to spammers and relayers?

Thanks
Aly

Admin
Site Admin
Posts: 825
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Post by Admin » Tue Nov 26, 2002 10:20 am

You will need to allow the local server to relay. This can easily be done in the SMTP Relay options:

1) Enable the Allow relay for privileged IP ranges
2) Click the Privileged IPs button
3) Make sure By default, all computers will be Denied relay rights is selected
4) Add the IP address 127.0.0.1
5) Click Close, then Apply.

This will allow anything on the local machine to send out email without having to be authenticated, but still stop remote machines from relaying.

Alyson_J
Posts: 40
Joined: Sat Jun 15, 2002 9:44 pm
Location: United Kingdom
Contact:

Post by Alyson_J » Tue Nov 26, 2002 11:19 am

Hi there and thanks for the prompt response.

I checked the SMTP relay properties and I already have all machines denied access, but had allowed 127.0.0.1

So that should work, but isn't.

An example from the logs follows, the mail address is correct in the logs but I have munged it here to prevent it being harvested.


11/26/02 05:35:50 SMTP-IN 272 127.0.0.1 HELO HELO 250 Requested mail action okay, completed 43 7
11/26/02 05:35:50 SMTP-IN 272 127.0.0.1 MAIL MAIL FROM:<name@correctdomain> 250 Requested mail action okay, completed 43 37
11/26/02 05:35:50 SMTP-IN 272 127.0.0.1 RCPT RCPT TO:<name@correctdomain> 554 The IP Address of the sender (127.0.0.1) was found in a DNS Blacklist SPAM database and was therefore refused. 116 36
11/26/02 06:17:10 SMTP-IN 284 127.0.0.1 220 grrlfriends.org.uk ESMTP Mail Enable SMTP Service, Version: 1.610-1.0014- ready at 11/26/02 06:17:10 0 0

I have all of the preset blacklists enabled plus I've added blocks for korea,china,brazil,argentina and taiwan

I guess this could be an interation with one of the relay blacklists?
Aly

Admin
Site Admin
Posts: 825
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Post by Admin » Tue Nov 26, 2002 2:57 pm

Yes, the issue appeared to be that if your IP was authenticated it will still check the blacklisting. There is a SMTP fix which should fix this issue at:

http://www.mailenable.com/hotfix

Please email support@mailenable.com if this doesn't resolve your problem.

Alyson_J
Posts: 40
Joined: Sat Jun 15, 2002 9:44 pm
Location: United Kingdom
Contact:

Post by Alyson_J » Tue Nov 26, 2002 3:40 pm

Thanks again for the follow up and the hotfix.

Just to say that this resolved the issue perfectly.

Thanks
Aly

Post Reply