404 error in mewebmail

Discussions on webmail and the Professional version.
Post Reply
merk
Posts: 418
Joined: Sun Oct 12, 2003 2:50 pm

404 error in mewebmail

Post by merk » Sun Dec 07, 2003 5:46 pm

I assume there is a time out with the webmail pages? i.e. if i am idle for 20 minutes i have to log back in?

Whenever i am idle for a while and then click on the check mail button, i get the IIS 404 error message. I would think it should either pop up a message telling me to log in again, or it should just redirect me to the login page. I'm guessing that it showing a 404 error is not whats supposed to happen.

BlueRocket
Posts: 49
Joined: Wed Oct 29, 2003 3:25 am

Post by BlueRocket » Mon Dec 08, 2003 2:19 am

Ya, I get this too. I think there is a mistake in the page name that it is trying to redirect to.

I've been meaning to post about that, but I keep forgetting.
"I have no special talents, I am only passionately curious" - Albert Einstein

merk
Posts: 418
Joined: Sun Oct 12, 2003 2:50 pm

Post by merk » Mon Dec 08, 2003 2:22 am

i havent bothered looking at the asp code. Figure i'd let support fix it rather then try to fix it myself ... being lazy :)

BlueRocket
Posts: 49
Joined: Wed Oct 29, 2003 3:25 am

Post by BlueRocket » Mon Dec 08, 2003 2:25 am

I don't like making changes to the ASP because it can get replaced on the next update. Then my work is lost. :(

I'm just waiting for the page to time out again, and then I can check what it's looking for versus what the page is actually called. :D
"I have no special talents, I am only passionately curious" - Albert Einstein

BlueRocket
Posts: 49
Joined: Wed Oct 29, 2003 3:25 am

Post by BlueRocket » Mon Dec 08, 2003 3:25 am

Found the bug. The page that is trying to load has the following path:

http://mail.MyServer.com/base/default/l ... imeout.asp

The correct path should be:

http://mail.MyServer.com/mewebmail/base ... imeout.asp

To fix this bug edit Sec.asp found in here --> C:\Program Files\Mail Enable\BIN\WebMail\base\default\lang\EN\Forms\MAI

The redirection is set to:

Code: Select all

Response.Redirect Application("MEWebPath") & "/base/default/lang/en/timeout.asp"
Add "mewebmail" at the start of the string, so it looks like this:

Code: Select all

Response.Redirect Application("MEWebPath") & "/mewebmail/base/default/lang/en/timeout.asp"
This should fix the problem. Hopefully it will be updated in a future release. I am currently waiting for it to timeout again, and then I'll know if the change worked or not. :wink:

*Server names have been changed to protect the innocent. :D
"I have no special talents, I am only passionately curious" - Albert Einstein

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Wed Apr 14, 2004 1:10 am

Michael, Thanks for bringing this to our attention. The issue is most likely caused by IIS web application recycling that was introduced into IIS 6 (ie: Windows 2003). The problem is that Application variables are no longer persistant, and as such considerations are required to ensure that they are loaded should they expire (as the result of IIS recycling the web application). The patch will be in the next release of 1.18 professional edition (which is due for release within the next few days). The patch is listed as follows:

Code: Select all

<%
	'make sure the person is logged in
	If Session("valid")<> True Then
		If InStr(1,UCase(Request.ServerVariables("HTTP_REFERER")),"/LOGIN.ASP") Then
			Response.Write ("<html><head><META name=""ROBOTS"" content=""NOINDEX,NOFOLLOW""><LINK REL=""stylesheet"" TYPE=""text/css"" HREF=""/mewebmail/base/default/skins/default/me.css""></head>")
			Response.Write ("<BODY BGCOLOR=""#DFDFDF"">")
			Response.Write ("<H1>Timeout Error</H1>")
			Response.Write ("Your browser session has timed out. You need to restart your webmail session.<BR><BR>")
			Response.Write ("If you have only recently logged in, it may be that your browser does not have Cookies enabled.<BR><BR>")
			Response.Write ("MailEnable WebMail Requires that your browser supports Cookies.<BR>")
			Response.Write ("Please check your browser settings, close all browser windows and retry.")
			Response.Write ("MailEnable WebMail Requires that your browser supports Cookies.")
			Response.Write ("</BODY</HTML>")
			Response.End
		End If
		If Not Application("Initialised") = True Then
			On Error Resume Next
			Set oOptions = Server.CreateObject("MEWebmail.Options")
			If Err <> 0 Then
				ReportApplicationError "MailEnable WebMail","MTS/COM+ MEWebMail.Options",Err,Err.Description
			End If
			WebMailWebPath=oOptions.GetOptionString("WebMailWebPath","","")
			If Len(CStr(WebMailWebPath)) = 0 Then
				If oOptions.GetOptionValue("ForceRootPath","","") = 1 Then
					WebMailWebPath = ""
				Else
					WebMailWebPath = "/MEWebmail"
				End If
			End If
			Set oOptions = Nothing
			Application.Lock
			' Set the records per page variable
			Application("MEWebPath")=WebMailWebPath
			Application.Unlock
		End If
		Response.Redirect Application("MEWebPath") & "/base/default/lang/en/timeout.asp"
	End If
%>
Regards, Andrew

MrByte
Posts: 663
Joined: Tue Nov 11, 2003 5:33 pm
Location: Florida, USA

Post by MrByte » Wed Apr 14, 2004 4:04 am

Andrew, would it be possible to have a "pop up" window that alerts the user that the session is timing out? Just letting him know that he has timed out is not good enough, I think. It has happened to me that I start replying an e-mail and do other stuff and then suddenly when I press the send, I get the error and lost what I just did.

Any toughts on this?
.MrByte

merk
Posts: 418
Joined: Sun Oct 12, 2003 2:50 pm

Post by merk » Wed Apr 14, 2004 6:43 am

if you had a pop up window, the session would probably never time out. The way sessions normally work is if you dont click anything, dont open a page etc etc then after 20 minutes (or whatever the programmer sets the default to) the session times out. But by opening another page, it would reset the session timer.

Although i think you could programmatically control the popup page so that it doesnt effect the session timer. Not 100% sure on that.

MrByte
Posts: 663
Joined: Tue Nov 11, 2003 5:33 pm
Location: Florida, USA

Post by MrByte » Wed Apr 14, 2004 9:56 am

yes, I know that. Normally it just gives the user xx seconds to answer and then the session will timeout anyway.
.MrByte

merk
Posts: 418
Joined: Sun Oct 12, 2003 2:50 pm

Post by merk » Wed Apr 14, 2004 9:58 pm

ahh yeah, ok i didnt think of that. You could have the popup window itself actually kill the session.

personally i hate popups though, so if they do implement this i hope its something that can be turned on or off. I'd rather they just stick a little java clock on the page somewhere, maybe have it make a beep 2 minutes before it times out.

MrByte
Posts: 663
Joined: Tue Nov 11, 2003 5:33 pm
Location: Florida, USA

Post by MrByte » Wed Apr 14, 2004 11:06 pm

well some sort of warning, something that at least doesn't make you loose what you are doing....
.MrByte

einarsen
Posts: 14
Joined: Thu Apr 22, 2004 2:43 am
Contact:

Related (?) 404 error

Post by einarsen » Mon Apr 26, 2004 1:48 am

I just moved over all my users to Mail Enable on a Windows 2000 Server. Everything was fine this afternoon, I ran the iis lockdown tool and tested webmail... it worked fine.

Now that I'm at home, however, I'm getting 404 errors when I log on. I diagnosed the problem to an incorrect language item in the URL.

The page is trying to go to:

http://mail.domain.ca/MEWebmail/base/de ... efault.asp

It SHOULD be going to:

http://mail.domain.ca/MEWebmail/base/de ... efault.asp

If I manually change the URL it works.

I backed out the iis lockdown tool and webmail still fails. Very frustrating... especially since it was working beautifully this afternoon.

I'm at a loss as to what could be different, but there seems to be some variable replacement problem.

Please give some direction as to a fix.

Thanks,
Brad Einarsen

einarsen
Posts: 14
Joined: Thu Apr 22, 2004 2:43 am
Contact:

If you can't beat 'em...

Post by einarsen » Mon Apr 26, 2004 2:01 am

Well, after looking at the code and determining that something was going on with LanguageID (hey, I'm not a programmer, so this was a feat for me) I decided if you can't beat 'em, join 'em.

I copied the directory

...\WebMail\base\default\lang\EN

to

...\WebMail\base\default\lang\1

And, of course, this solved the problem.

Now I'm going to try running IIS Lockdown again... I suspect it'll be ok now.

Please let me know when there's a fix for this language thing.

--Brad

Post Reply