Changing outgoing SMTP Port stops Incoming mail

workitonline
Posts: 1
Joined: Fri Mar 24, 2017 9:15 am

Changing outgoing SMTP Port stops Incoming mail

Postby workitonline » Fri Mar 24, 2017 9:17 am

We have had issues with someone trying to SPAM our outgoing mail server, sending emails to .com.tw domains. We require authorisation, so they don't send, but they still use up significant resources on the server and delay sending of legitimate mail.
We have tried to block IP addresses, but new ones just keep occurring constantly - over a period of weeks.
On the Mail Enable Professional application, on the SMTP connector I have changed the Inbound > Port Settings to for the SMTP to listen on port 666, which I have successfully SENT email through.
This stops the SPAM senders from being able to try and send, greatly reducing the traffic and use on the server.
However, for some reason, this means our mailboxes cannot receive emails anymore (except from local addresses), with no emails even appearing in the STMP activity or debug logs.

Changing the port back to 25 allows emails to be received, but opens up the spam issue again.

Is it possible that Mail Enable only sends through port 666, but it is still possible to receive emails using IMAP as normal on port 25?

I have since changed back to port 25 so we can receive emails, and now the server has over 100mb log file from the last 2 hours as the SPAM is attempted to send through.

MailEnable-Ian
Site Admin
Posts: 8557
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Changing outgoing SMTP Port stops Incoming mail

Postby MailEnable-Ian » Tue Mar 28, 2017 10:38 pm

HI,

All mail servers will send over port 25. Therefore you need to configure the MailEnable SMTP service to listen on port 25 in order to be able to accept emails from other mail servers. Your problems with spam messages being relayed from your server will most likely be a misconfiguration of the SMTP relay settings or that a mailbox password has been compromised and the spammer is successfully authenticating and being grated relay rights.

For the SMTP relay settings ensure that you have not set the "Allow privileged IP's to relay" to "Granted all - except those in the list" as this will open the server up for relay and allow any IP address to relay messages. Also ensure that the relay option for "Allow relay for local sender addresses" is not ticked.

To check is the spammer is being granted relay rights by successfully authenticating you need to inspect the SMTP activity and debug log files and trace through to see which mailbox the spammer is using the authenticate. The easiest way to do this would be to navigate to the SMTP > Outgoing queue in the administration console and double click a spam message sitting in the outgoing queue. It will report the mailbox that was used to authenticate. Once you know the mailbox you need to change the password and make it a complex a password.

Here are some articles to help further with your problems:

http://www.mailenable.com/kb/content/article.asp?ID=me020339
http://www.mailenable.com/kb/content/article.asp?ID=me020168
http://www.mailenable.com/kb/content/article.asp?ID=me020280
http://www.mailenable.com/kb/content/article.asp?ID=me020250

NOTE: IMAP does not send or receive messages. SMTP is the responsible service for sending/receiving emails. Your clients will connect to the MailEnable server via IMAP to retrieve their messages in the store folders and send messages via SMTP.
Regards,

Ian Margarone
MailEnable Support

Who is online

Users browsing this forum: No registered users and 1 guest