auto response and outlook.com

Discussions on webmail and the Professional version.
Post Reply
lesgray
Posts: 8
Joined: Wed Dec 12, 2018 7:13 pm

auto response and outlook.com

Post by lesgray » Wed Dec 11, 2019 7:54 pm

Hi;

I set an auto response which is working for every mail server I can test including gmail, however mail sent from an outlook.com account does not get an auto response reply. Anyone have any idea why that would be? EDIT: DKIM , DMARC and SPF are all setup and working correctly
Last edited by lesgray on Thu Dec 12, 2019 9:12 pm, edited 1 time in total.

lesgray
Posts: 8
Joined: Wed Dec 12, 2018 7:13 pm

Re: auto response and outlook.com

Post by lesgray » Wed Dec 11, 2019 9:46 pm

Logs show multiple entries like:

[0A29486ADA7D410F95E23EF8E3B15740.MAI] Sent autoresponder from PO=*******.com MBX=***** to [SMTP:SRS0=sawc=2B=outlook.com=*******@ik2.com]. New message

Multiple entries because we have tried several times to get the auto reply to work, each entry is diffferent and is preceded by one like this:

[0A29486ADA7D410F95E23EF8E3B15740.MAI] Delivered message from [SMTP:SRS0=sawc=2B=outlook.com=*******@ik2.com] to PO=*******.com MBX=****** FLD=\Inbox

The usernames and domain names which I have replaced with asterisks are correct. Nothing shows up at username @outlook.com email....

Additional Information:

not sure if this would impact anything.

In the headers from an email account (different mail server sending it) I see this:

Precedence: auto_reply

In the headers of the email account I cannot receive auto-replies from (this is from a non Outlook.com account) I see this:

Precedence: bulk

lesgray
Posts: 8
Joined: Wed Dec 12, 2018 7:13 pm

Re: auto response and outlook.com

Post by lesgray » Mon Jan 20, 2020 6:30 pm

This issue has now been resolved. The problem arose from a setting in our spam filtering service, MXGuardDog. After going through the headers once again, I noticed something odd. It showed that the autoreply emails had a header showing the emails coming from the MXGuardDog servers and not our own. Non auto reply emails showed our email server as the sending server.



I contacted MXGuardDog SUpport:

me: why does our outgoing mail show an .ik2 server as the sending server?

MXGD: MX Guarddog does not provide any outbound mail service at all, you can't send mail through our network so your outgoing mail should certainly not show any .ik2 references.

me: Well, that is the odd thing. Check out these headers, they seem to show the outgoing server to be an .ik2 one

MXGD: OK, I see. That is the correct operation actually. It is an auto-reply, which goes back out through our servers.

It is part of SPF/SRS security, which is enabled by default. If you are 100% certain that your server does not do SPF checking on incoming mail you can disable the feature on your email server page. It is listed as Sender Rewriting Scheme (SRS). If you disable that, your auto-replies will not go back out through our servers.

If your server does have SPF checking (or you are not sure) you must leave the SRS option enabled or your server will reject a bunch of mail from our servers.

me: OK, I understand now. Well, I assume your servers check SPF, DMARC, PTR etc prior to sending mail through, correct. I can turn SPF checking off, if it would be safe to do so. What would be your opinion on that?

MXGD: Yes, you can safely turn off SPF checking on your server as we perform that check

Epilogue:

I turned off SRS as suggested and immediately auto reply emails began getting through to outlook.com and Office 365 hosted emails.

Post Reply