Smarthost Domain's priority not working

Discussions on webmail and the Professional version.
Post Reply
Posts: 1
Joined: Sun Feb 05, 2023 5:40 pm

Smarthost Domain's priority not working

Post by starlinalmonte »


I have an issue with multiple servers and Smart Host. The servers use an external Smart Host for filtering purposes, but some domains might present some issues with this setup, thus having these domains skip the external Smart Host and use the local server only it's a good option

In the past I recall having the "Domain smart hosting takes priority" setting under SMTP --> Smart Host enabled, and configuring the domains I'd like to skip the Server-Wide Smart Host to use under the Postoffice Properties.

But recently these are not working, and all domains are using the Server-Wide Smart Host. Tested on all versions from 10.40+ and it's the same.

Is this a known issue, or is there any solution for this?

Site Admin
Posts: 1093
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Re: Smarthost Domain's priority not working

Post by Admin »

The postoffice option "Smarthost all outbound email for postoffice" will always override the SMTP smarthost setting. The "Domain smart hosting takes priority" is for the smart host settings under a domain (not the postoffice). This is where you are redirecting unknown emails going to that domain to a specific IP address (generally used for when sharing namespace with another SMTP server). I think you will need to check the SMTP Debug log as it will indicate what it is doing with the outbound email for the postoffice. Also, in order for the postoffice one to work the email being sent has to be linked to that postoffice in some way - this is normally set when the user sending authenticates. Maybe it is not able to determine the message is being sent from a postoffice user.

Post Reply