AutoREsponder From Address

Discussions on webmail and the Professional version.
JohnC
Posts: 67
Joined: Fri Dec 17, 2004 10:57 am
Location: Edinburgh, Scotland

AutoREsponder From Address

Post by JohnC » Thu Jan 20, 2005 4:22 pm

When I have the autoresponder on the message sent back has the from address set to 'AutoREsponder' not my name. To see who is out of the office you have to look at the headers. Is there somewhere I can change this? If not is it a bug? It is IMHO.

JohnC

MailEnable-Ian
Site Admin
Posts: 9162
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Post by MailEnable-Ian » Thu Jan 20, 2005 11:17 pm

Hi,

You can alter the autoresponse.cfg file for the mailbox. Navigate to C:\Program Files\Mail Enable\Postoffices\(postofficename)\MAILROOT\(Mailboxname) and locate the "Autoresponse.CFG" file. Right click the file and open with notepad and chnage te line in the "From:" field to your specific name or address or just delete "auto response" and leave the address.

regards,

JohnC
Posts: 67
Joined: Fri Dec 17, 2004 10:57 am
Location: Edinburgh, Scotland

Post by JohnC » Fri Jan 21, 2005 11:25 am

Thanks Ian
That's going to be a hassle when I transfer over all my users to ME. I suppose I could script a fixup.

It still seems perverse to me that the autoresponder does tot tell the sender who is responding by default. A bug IMHO.

John C
Edinburgh

cassius
Posts: 338
Joined: Tue Mar 11, 2003 2:29 pm
Location: Indianapolis, IN

Post by cassius » Fri Jan 21, 2005 6:37 pm

I agree completely here, the autoresponders should default to come from the mailbox it was set for, NOT the postmaster.

JohnC
Posts: 67
Joined: Fri Dec 17, 2004 10:57 am
Location: Edinburgh, Scotland

Post by JohnC » Mon Jan 24, 2005 10:57 am

Digging into the code it appears that it is trying to use the user and not the system address but defaulting because the call fails:

set oOptions = server.CreateObject("MEWebMail.Options")

sReplyTo = oOptions.GetSystemOption("2", PostOffice & "/" & UserName, "ReplyAddress")

If Len(sReplyTo) = 0 Then
sReplyTo = oOptions.GetSMTPBadMailAddress()
End If

Seems to be a bug in the MEWebmail.Options object.

John C

JohnC
Posts: 67
Joined: Fri Dec 17, 2004 10:57 am
Location: Edinburgh, Scotland

Post by JohnC » Mon Jan 24, 2005 11:49 am

I need this to work ASAP so I've fixed it myself -
If you want to get autoresponders to show who its from make these changes to the autoresponders.asp script

REmove orcomment out these 2 lines

'set oOptions = server.CreateObject("MEWebMail.Options")
'sReplyTo = oOptions.GetSystemOption("2", PostOffice & "/" & UserName, "ReplyAddress")

Add this code

set oOptions = server.CreateObject("MEAOSO.Option")
oOptions.Query = PostOffice & "/" & UserName
oOptions.scope = 2
oOptions.ValueName="ReplyAddress"
oOptions.GetOption()

sReplyTo = oOptions.Value
If Len(sReplyTo) = 0 Then
sReplyTo = oOptions.GetSMTPBadMailAddress()
End If

set oOptions = nothing

Works for me

Cheers
JohnC

sdewitt
Posts: 64
Joined: Sun Mar 07, 2004 6:24 pm
Location: Atlanta, GA USA

Post by sdewitt » Wed Apr 27, 2005 1:05 pm

Ok this is now biting me. My users are saying when they turn on autoresponse while they are out of the office that users recieve a response and they have no I dea who it was from because it is not using the correct from email. This is annoying.

Shannon

MailEnable-Ian
Site Admin
Posts: 9162
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Post by MailEnable-Ian » Thu Apr 28, 2005 1:36 am

Hi,

You need to set the reply-to address for the mailbox. Navigate to the mailbox properties in the Mailenable console program and go to the "addresses" tab. Here you can specify the reply-to address that will be used for the autoresponder. If you do not have a reply-to address configured and you enable the autoresponder, it will automatically default to reply from the postmaster account.

One problem is, if you have the autoresponder option enabled for a mailbox and the Autorespond.CFG file has been created, it will not update the file if you go and change the reply-to address for the mailbox. You need to first disable the autoresponder option and then set the reply-to address, enable autoresponder and it will create a new Autorespond.CFG file with the updated reply-to address. This problem has been added to our issue register and will be addressed in the upcoming releases.

regards,

pdunlop
Posts: 20
Joined: Tue Aug 13, 2002 6:51 pm
Location: Monbulk, Victoria, Australia

Post by pdunlop » Thu Apr 28, 2005 1:40 am

Thanks for the tip Ian.

I was just playing around with this and was wondering why setting the reply address seemed to make no difference.

As suggested, I have tried disabling the autoresponse action for the mailbox, setting the correct reply address, then re-enabling the autoresponder - unfortunately, only the replyto component of the sender details has changed. The friendly name still shows as postmaster, so it still appears at first glance to be from the postmaster rather than the specific mailbox
Last edited by pdunlop on Thu Apr 28, 2005 1:51 am, edited 1 time in total.

MailEnable-Ian
Site Admin
Posts: 9162
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Post by MailEnable-Ian » Thu Apr 28, 2005 1:49 am

Hi,

Have you checked the Autorespond.CFG file located in the mailbox's directory to see if the reply-to address was written? You may try deleting the file and then disbaling/enbaling the option again to create the new file.

You can find the file in :
C:\Program Files\Mail Enable\Postoffices\postofficename\MAILROOT\mailboxname

regards,

pdunlop
Posts: 20
Joined: Tue Aug 13, 2002 6:51 pm
Location: Monbulk, Victoria, Australia

Post by pdunlop » Thu Apr 28, 2005 1:54 am

Hi Ian

I was just editing my last post to say that the reply to HAD changed, but not the friendly name (which is all that some people see).

MailEnable-Ian
Site Admin
Posts: 9162
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Post by MailEnable-Ian » Thu Apr 28, 2005 1:58 am

Hi,

The "Auto Repsonse" tag you see in the from field, will need to be manually changed in the file itself. Just remember that if you disable/enable the option the file will be re-created and the tag will then default back to "Auto repsonse".

regards,

JVRudnick
Posts: 237
Joined: Thu Jun 03, 2004 4:04 pm

Rebirth of an older thread...but on point...

Post by JVRudnick » Thu Dec 22, 2005 5:07 pm

hello all...

been following the workings of trying to get the AR to show the person to whom the email was sent in the FROM field.

read all here, and while I've been able to get the email address changed properly, the dang Friendly name shows up STILL as "Auto Reponse"

I have tried all of the fixes here, short of writing new code...

Can someone offer, IS there a way to set the Friendly name to the persons name?

Jim

someone_else
Posts: 302
Joined: Tue Jul 19, 2005 1:12 pm
Location: 404

more shamless plugs

Post by someone_else » Thu Dec 22, 2005 9:10 pm

Well, you could try my Out-of-Office utility, as it does use friendly names, and is currently more RFC compliant than the built-in autresponder functionality of ME.
MailEnable plugins:
DKeyEvent - DomainKeys/DKIM
MESpamC - SpamAssassin integration

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Fri Dec 23, 2005 2:07 am

Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

Post Reply