Server.CreateObject Failed ASP 0177 : 800401f3

Discussion for developers using MailEnable.
Post Reply
jpb1904
Posts: 2
Joined: Mon Jan 10, 2022 6:46 pm
Location: Netherlands

Server.CreateObject Failed ASP 0177 : 800401f3

Post by jpb1904 » Tue Jan 11, 2022 11:53 am

My system is Windows 2003 server with MailEnable installed from Plesk.

I start the demo version of Classic ASP and the login.asp stops immediatley on ths line Set oOptions = Server.CreateObject("MEWebmail.Options") with error "Server object error 'ASP 0177 : 800401f3' Server.CreateObject Failed"

I read all forum posts on this and did the following, with no luck:
- found out where MEASP.DLL is installed
- regsvr32 MEASP.DLL
- added folder where MEASP.DLL is installed to path
- gave MEASP.DLL and later the complete folder Read and Execute permissions to pool-user, IME_USER and in the end 'everyone'

Nothing helped. Today is january 2022 and the latest posts are from years ago, so there must be a solution for this. This might be a Plesk thing?

Admin
Site Admin
Posts: 880
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Re: Server.CreateObject Failed ASP 0177 : 800401f3

Post by Admin » Tue Jan 11, 2022 10:35 pm

Hi,

Are you running the site as 32bit? The old webmail example will only run as 32bit. Also, the DLL it uses for that is MEAPWMS.DLL. You are best using a COM+ package for the DLL though, it will make it easier. That classic webmail though should just be used as an example, you shouldn't install it on public site.

jpb1904
Posts: 2
Joined: Mon Jan 10, 2022 6:46 pm
Location: Netherlands

Re: Server.CreateObject Failed ASP 0177 : 800401f3

Post by jpb1904 » Tue Jan 18, 2022 10:00 am

Thank you for your answer. The site is running in a 64bit environment, however the development environment is classic-ASP, so how can I use/setup a COM+ package for the DLL?

Admin
Site Admin
Posts: 880
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Re: Server.CreateObject Failed ASP 0177 : 800401f3

Post by Admin » Fri Jan 21, 2022 5:32 am

Hi,

You will need to run it as 32bit. The old webmail will fail to run properly under 64bit. You can find details of setting up the DLL at:

https://www.mailenable.com/kb/content/article.asp?ID=ME020092

You'll need to follow the manual steps listed.

Post Reply