MailEnable WAS and Zebrahost

Bagalan
Posts: 1
Joined: Mon May 06, 2019 5:40 am
Location: https://grillfaq.com/

MailEnable WAS and Zebrahost

Postby Bagalan » Mon May 06, 2019 6:52 am

Hi All,

Clive at zebrahost as setup me up with a server. The Web application server and Mailenable have both been setup. Everything is working fine but I can't figure out how to get the email settings correct.

With mailenable I have been able to setup a couple mailboxes and download and send email using Eudora. So everything good there.

What I can't figure out is how to setup the xbasic code to send emails through the mailenable server. What I want to happen is that when one of my users sends an email using my alpha 5 application, the from email should be their own email address.

I have included my code below, but I can't figure out if I have the port incorrect, or the SMTP server incorrect, or if I need to change a setting on mailenable....(Clive has opened ports 25 and 110)

Any help would be much appreciated!

Here is my current code:

vTo = email_address_cust 'This value prefilled in select statement
vFrom = email_address 'This value prefilled in select statement
v_fromalias = company_name 'This value prefilled in select statment
v_subject = "Attached is your Invoice from " + company_name


dim pm as P
dim ps as P
dim email_result as l
'vMessageStr = "here is my messsage."
flag = email_smtp_open(ps, "smtp.mail.supportsolutions.com", 110, email_address, "password")
if flag = .f. then
?"error"
'report an error to the user
end
end if
pm._to = vTo
pm.from = vFrom
pm.from_alias = v_fromalias
pm.subject = v_subject
pm.attachments = filename
'pm.html_message = "<HTML><strong>This is really great!</strong><br><br></HTML>"
'pm.html_message = pm.html_message+"<HTML>this is a test</HTML>"
pm.html_message = "Hi There, <br> Attached is your invoice."
email_result = email_smtp_send(pm, ps)
email_smtp_close(ps)

Who is online

Users browsing this forum: No registered users and 5 guests