WebMail in French!

Discussion forum for Enterprise Edition.
Post Reply
Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

WebMail in French!

Post by Cyberprog » Tue Jan 16, 2007 5:03 pm

Hi There,
We have an odd issue with our install of Mailenable Enterprise, it's displaying it's webmail in french, not english. Works fine on one of our sites, but all the others (which is just a website running on an IP with lots of virtual domains pointed at that IP). How can I change the default language? Been looking all over the code, but can't find anything!

Cheers!
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Wed Jan 17, 2007 5:06 am

If you are using a Host Header configuration then you can find the default settings for each web mail site at;

ME Admin MMC->Servers->Localhost->Services->WebMail (left Click)->In the right hand panel you will see each host header with the default web mail settings.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

Post by Cyberprog » Wed Jan 17, 2007 1:45 pm

We're not configuring them individually, because of the number we have :)
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Wed Jan 17, 2007 11:39 pm

In that case the path could be pointing to French. What is the path after you have loaded web mail if it is;

http://domain.com/enterprise/lang/fr/Forms/default.aspx

It needs to be;

http://domain.com/enterprise/lang/en/Forms/default.aspx

Make sure that you remove you client side explorer caching in case it was selected wrong once before or the save settings for this computer was selected incorrectly.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

Post by Cyberprog » Thu Jan 18, 2007 12:31 am

Nope, we direct to http://webmail.domain.com/

Here's an example of how f***ed up it is!:

http://webmail.moulsford.com/enterprise ... login.aspx

English page, french language.

The local path for the webmail in IIS is C:\Program Files\Mail Enable\BIN\NETWebMail

http://mail.cube-media.com/ works perfectly, but that may be because it's been modified in the utility
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Thu Jan 18, 2007 1:31 am

Make sure you are running the latest version as there was a problem in this area about one year ago.

Now though the program will decipher languages in this order;

1. When the page loads it will check for any valid cookies and use them to load the language default and any other options configured for the client.

2. If the above is not correct then it will use the host header settings that I have mentioned earlier.

3. If the above is not possible it will default to English.

Try this link for your web mail;

http://webmail.moulsford.com

This went to a default path of French for me meaning the settings in your host headers are configured for French.

http://webmail.moulsford.com/enterprise ... login.aspx
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

Post by Cyberprog » Thu Jan 18, 2007 1:53 am

Ok, we're using 2.32, but it's been upgraded from god knows what versions in the past.

1. Does it on a clean install of xp that's never visited before.
2. There are *no* host header settings defined, so I created one the same as my Pro install (which is configured the same way with an IIS web running on an IP and then people's webmails just set with a dns entry pointing at that ip, i.e. no reconfiguration needed when we add a website.
3. And then it defaults to french!

Is there any way to *force* it to english? Or anywhere it might be storing the knackered setting?
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

Post by Cyberprog » Thu Jan 18, 2007 1:55 am

As an interesting abendum, if I try and make a host header for webmail.moulsford.com, it erm, breaks for that domain!
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Thu Jan 18, 2007 2:06 am

What are the contents of the Program Files\MailEnable\Config\SITE-LANGUAGE.TAB file?

Maybe the language set in here is FR rather than EN.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

Post by Cyberprog » Thu Jan 18, 2007 2:14 am

Yes! Thank you so much!
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Thu Jan 18, 2007 2:43 am

No problems if you are interested, this is most likely what happened;

Before July last year a host header was created for this domain it was then removed. The problem back then was not all the configuration files were being removed correctly. So the site-language.tab file being one of these files that was not removed was set to French for your web mail site. As such it appeared as though you had a host header configured for the web site but actually it was not, the legacy FR setting in the site-language.tab file was still setting the default language as French.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

Cyberprog
Posts: 57
Joined: Mon Aug 19, 2002 9:48 pm
Location: Bristol, UK

Post by Cyberprog » Thu Jan 18, 2007 2:58 am

it was the entry under default that was set to fr, can't for the life of me work out why we would have set it to that though!
British Airways billboard ad: Breakfast in London, lunch in New York.
Spraycan addition: Luggage in Bermuda.

Post Reply