Webmail timeout...

Discussion forum for Enterprise Edition.
morgizzy
Posts: 12
Joined: Tue Apr 18, 2006 9:19 pm

Webmail timeout...

Post by morgizzy » Sun Jan 06, 2008 5:08 pm

hey guys...

I am running Mail Enable Enterprise v3 and can't seem to find any concrete info on setting / finding out what the webmail timeout settings are... I remember being able to do this through the registry for v2 but don't know if the same exists for v3...

Any info into this topic would be greatly appreciated..

thanks guys!

Matt

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Mon Jan 07, 2008 4:08 am

The timeout settings are now found in the properties of the MailEnable Application Pool you can find this in IIS under the folder of Application Pools.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

billyb
Posts: 40
Joined: Wed Nov 14, 2007 5:08 pm

Post by billyb » Mon Jan 07, 2008 8:50 pm

I must be looking in the wrong spot, but the only timeout I see for the porperties pages of the app pool is for worker processes shutdown idle timeout

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Tue Jan 08, 2008 3:29 am

Sorry yes my bad, I had the vision of the TAB but remembered it in the wrong location. You can find the session timeout value(s) in the following location;

IIS->Web Sites->Webmail Webpage properties (Either Host Header site or virtual directory)->Home Directory TAB OR Virtual Directory TAB->Configuration BUTTON->Options TAB.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

bsmith
Posts: 6
Joined: Wed Jan 09, 2008 8:52 pm

Post by bsmith » Wed Jan 09, 2008 9:02 pm

I am running professional when I change this value it doesn’t seem to affect my timeout. My users are still being dropped at 20 minutes, I have restarted the webpage plus all the ME services is there anything else I might need to do?

Thanks


Image

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Wed Jan 09, 2008 10:09 pm

Restart IIS and see if that helps.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

billyb
Posts: 40
Joined: Wed Nov 14, 2007 5:08 pm

Post by billyb » Wed Jan 09, 2008 11:07 pm

I was going to post the same thing, as my timeout is also still at 20 minutes (I have restarted IIS and the machine many times). If it matters, I am using only SSL for web connections. Could this have its own timeout?

bsmith
Posts: 6
Joined: Wed Jan 09, 2008 8:52 pm

Post by bsmith » Wed Jan 09, 2008 11:42 pm

Restarting IIS had no effect. :(

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Thu Jan 10, 2008 12:58 am

As far as I know there are two settings that need to be set in IIS;

1. Under the web page (either virtual directory (MEWEBMAIL) or the host header "MailEnable Webmail")) on the Virtual Directory TAB there is a [Configuration] button. When the next screen comes up click on the Options TAB and change the session state - timeout to 90 (or what ever the value you want to use)

2. Under the Application Pools folder listing there is an application pool named "MailEnableAppPool", get the properties of this. The click on the performance TAB and for the option "Shutdown worker process after being idle for time in minutes" make the value the same value that you used for the number one option.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

bsmith
Posts: 6
Joined: Wed Jan 09, 2008 8:52 pm

Post by bsmith » Thu Jan 10, 2008 4:12 pm

I have done both of those setting plus restarted many times now, its still timing out at 20 mins.

Is there anyone who has had successes in changing the timeout?

Thanks

MailEnable-Ben
Posts: 5858
Joined: Fri Jan 16, 2004 6:49 am
Location: Melbourne

Post by MailEnable-Ben » Fri Jan 11, 2008 12:40 am

If it is timing out at 20 minutes then either you have changed the wrong values (as the ones outlined above are default of 20) or there is another setting that is configured at 20 minutes which is affecting it. I suggest you find any 20s and change them also.

I changed the two settings to 90 and I am not timing out until 90 minutes. If you still have problems after trying the above then I suggest you submit a support request via the MailEnable web site under Environment and we will log in and check. If the problem ends up being another configuration within .NET or something new that needs configuring in .NET that I have not mentioned here then any charges will be refunded.
Regards,

Product Services
MailEnable Pty Ltd

To keep track of all ME company updates and version releases you should subscribe to the MailEnable list at http://www.mailenable.com or the RSS feed http://www.mailenable.com/rss.

MauryMac
Posts: 12
Joined: Wed Oct 10, 2007 4:36 am

Post by MauryMac » Fri Jan 11, 2008 7:40 pm

I remember reading yesterday about some sort of issue if you are using a redirect, but i lost it due to sleep mode not waking up. Just thought i might throw that in there. Something about webmail.domain.com not working, it should be domain.com/webmail to work properly. Might have been two different topics, but as i am having the same problem, im trying everything i can get my hands on.

Maury

mmuniz
Posts: 47
Joined: Sat Dec 02, 2006 8:00 am

Post by mmuniz » Fri Jan 11, 2008 11:34 pm

I have discovered that like me if you have a control panel like plesk and it uses webmail to login then you will find the mewebmail app pool there also and you will need to change that value.

bsmith
Posts: 6
Joined: Wed Jan 09, 2008 8:52 pm

Post by bsmith » Sat Jan 12, 2008 6:57 am

are you talking about within the plesk control panel, or under IIS?

mmuniz
Posts: 47
Joined: Sat Dec 02, 2006 8:00 am

Post by mmuniz » Sat Jan 12, 2008 4:06 pm

Under the IIS. It will be one of the virtual directories I warn that great care be taken to pay attention the asp.net version. Due to plesk originally having Horde if you change the settings on the webmail directory it will also save them to the mewebmail folder. This will cause it to replace the asp.net with 1.1 version instead of the 2.0 you may have set mailenable to use. These changes are not global it just affects the folders listed.

Image

Image

Image

Hope this helps. Please remember this is a configuration in Plesk I don't know if this is true for any other Control Panel.

Post Reply