Hung SMTP and high CPU sending while sending mail out

Discussion forum for Enterprise Edition.
Post Reply
dslchiphead
Posts: 69
Joined: Wed Jun 27, 2007 8:47 pm

Hung SMTP and high CPU sending while sending mail out

Post by dslchiphead » Mon Dec 13, 2010 7:32 pm

We are using Enterprise V4.12. We can not upgrade at the moment for various internal QA and upgrade procedures we have.

I've had another problem with the ME software again in which mail does not go out. No one realized that and mail was stuck since last Wednesday until this AM. People are now upset to the extreme and calling for heads to roll. This is not the first time this has happen. It may be time to look for a new product. I wish ME had a monitoring process that could alert to possible problems. But again, I could bring in a external monitoring solution as well.

Overtime the outbound queue fills and mail does not send out to our Smart Host. The MESMTPC.EXE process is running with very high CPU time. No errors or odd messages in any logs. No virus checking is done nor do we use Webmail. Just basic SMTP in/out. If I restart all the ME Services then the outbound queue empties.

I had asked ME Support a couple of times but was unable to find the cause. Due to the time difference, debugging is hard with no support contract and the need to get the product working again ASAP here. Initially we thought it was the Virus Checking but now I am not too sure that was it.

Has anyone come across this before?

-Dave

MailEnable-Ian
Site Admin
Posts: 9145
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Hung SMTP and high CPU sending while sending mail out

Post by MailEnable-Ian » Tue Dec 14, 2010 2:50 am

Hi,

Firstly, I suggest you consider upgrading to the current release of version 4, as it contains a security hot fix that you need to apply (ie: 4.12 has been updated and 4.26 is the current version).

It is also possible that the newer release has improvements that may overcome or give more insight into your problem.

It is possible to monitor the outbound activity of the SMTP connector using the metray utility. If you click on inbound or outbound lines, it will show you in real time active inbound and outbound sessions. This should give you an indication as to what the connector is actually doing and how much mail it is sending.

If the problem persists after performing the upgrade then I would suggest lodging a support ticket under the category of "upgrade" (free charge) and provide copies of the SMTP debug and activity log files in respect to your tests so that a technician can inspect further.
Regards,

Ian Margarone
MailEnable Support

dslchiphead
Posts: 69
Joined: Wed Jun 27, 2007 8:47 pm

Re: Hung SMTP and high CPU sending while sending mail out

Post by dslchiphead » Tue Dec 14, 2010 4:53 pm

Thanks Ian. I will upgrade this Thursday as I just got approval from our QA department.

Post Reply