[Solved]WebMail and Webadmin can't be seen from the internet

Discussion forum for Enterprise Edition.
Post Reply
Ehenzel1978
Posts: 98
Joined: Mon Dec 31, 2012 4:48 pm
Location: Leland, NC 28451

[Solved]WebMail and Webadmin can't be seen from the internet

Post by Ehenzel1978 » Mon Dec 31, 2012 5:54 pm

Hello,

I am new to MailEnable, and I am trying to get it setup to test it to see if it is the mail server for us. The issue I am having is that Webmail and Webadmin can't be seen from the internet. I can get to them just fine when I'm on the local network. On the local network Webmail sends and recieves just fine.

I am trying to set these up as a virtual directory, as we will only be hosting the one website.

The domain I am trying to use is test.leatheritaliausa.com, it resolves to the ip address 97.67.217.155, which is correct. I have only one website setup on the server, it's the default first name site. I don't actually have a site setup specifically for test.leatheritaliausa.com. I have tried putting in bindings so that test.leatheritaliausa.com goes to the default first name site, but I'm not sure if i have to create a dns record under the default first name site for it or not, and how do I create it if I do? I do have a forward lookup zone setup as test.leatheritaliausa.com that has A Records pointing the test.leatheritaliausa.com to my local servers, as well as the reverse lookup zones DNS records, and I think all this is correct because I am able to send and recieve just fine.

I am running windows server 2008 r2 64-bit, and I am trying to use IIS 7.5 to do this. Any help would be greatly appreciated.
Last edited by Ehenzel1978 on Mon Jan 07, 2013 3:14 pm, edited 1 time in total.
Eric Henzel
IT Department
Leather Italia USA

Ehenzel1978
Posts: 98
Joined: Mon Dec 31, 2012 4:48 pm
Location: Leland, NC 28451

Re: WebMail and Webadmin can't be seen from the internet

Post by Ehenzel1978 » Wed Jan 02, 2013 6:05 pm

Update:

i figured out that i didn't have the NAT policies setup correctly on my SonicWall router firewall. Once I got those setup I started getting "Server Error- 404 file or directory is missing."

And now I can't access the webmail locally anymore. I have checked to make sure the 32-bit is enabled in the app pool, it is. I have checked to make sure all the necessary role services are installed, they are. I have run the meinstaller from the bin folder, options 2 and 13 and set everything to .net version 2.0. I have gone into the handler mappings on my default first website and hit the revert to parent button.

Nevermind, I figured it out. The mailEnable webmail and webadmin don't like being under the default first website. Once I created a second website, and removed the bindings for the webmail and other from the default first site, it popped up just like it should be.
Eric Henzel
IT Department
Leather Italia USA

Post Reply