Script Filters Caused Crash

Discussion forum for Enterprise Edition.
Post Reply
tstrip111
Posts: 18
Joined: Tue Feb 10, 2015 2:52 pm

Script Filters Caused Crash

Post by tstrip111 » Tue Sep 20, 2016 1:37 pm

Hello,

I added the following script filter so that I could not allow sending to external domains (except for ones in domains.txt) and it caused a mailserver crash that led to me having to reboot the server.

FilterResult=0
If CriteriaMet([ME_FROM],"*@exampledomain.com*") AND _
not CriteriaMet([ME_TO],"<REFERENCE><FILE>domains.txt</FILE><PATH>C:\Program Files (x86)\Mail Enable\Config\Filters\Patterns</PATH><REFERENCE>") THEN
FilterResult=1
End If

Received this error:
General: (MailEnable SMTP Service error: 288) ME-I0145: Service Stopped

Followed by a ton of these:
Failure: (MailEnable SMTP Service error: 10013) - ME-F0090: Unable to bind to IP Address (127.0.0.1), Port (25), Error (10013). Could not start service. Check that another service is not running or security software has not prevented access to the port.

Are these errors related to me adding the script filter or are these errors caused by something else? I had to delete the filter thinking it was causing the issue. Any advice would be appreciated. Thanks

tstrip111
Posts: 18
Joined: Tue Feb 10, 2015 2:52 pm

Re: Script Filters Caused Crash

Post by tstrip111 » Tue Sep 20, 2016 4:28 pm

Ive also been seeing these errors:

Faulting application name: METray.exe, version: 1.0.0.0, time stamp: 0x54d46a56
Faulting module name: MSVCR90.dll, version: 9.0.30729.6161, time stamp: 0x4dace4e7
Exception code: 0xc0000417
Fault offset: 0x00000000000552d4
Faulting process id: 0x1320
Faulting application start time: 0x01d212a7823187d6
Faulting application path: C:\Program Files (x86)\Mail Enable\bin\METray.exe
Faulting module path: C:\Windows\WinSxS\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_08e61857a83bc251\MSVCR90.dll
Report Id: c9930889-7f4a-11e6-bdac-005056964611

MailEnable-Ian
Site Admin
Posts: 9253
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Script Filters Caused Crash

Post by MailEnable-Ian » Tue Sep 20, 2016 11:15 pm

Hi,
Received this error:
General: (MailEnable SMTP Service error: 288) ME-I0145: Service Stopped

Are these errors related to me adding the script filter or are these errors caused by something else? I had to delete the filter thinking it was causing the issue. Any advice would be appreciated. Thanks
No they are not related as the SMTP service is not responsible for loading filters. The MTA agent is. The SMTP service is most likely crashing for other reasons. You have not mentioned what version of MailEnable Enterprise your running. If not the latest then you will need to upgrade to eliminate issues in an old version that maybe causing the service to crash.
Followed by a ton of these:
Failure: (MailEnable SMTP Service error: 10013) - ME-F0090: Unable to bind to IP Address (127.0.0.1), Port (25), Error (10013). Could not start service. Check that another service is not running or security software has not prevented access to the port.
The above indicates that there is another service bound to 127.0.0.1 on port 25 and the MailEnable SMTP service could not bind to it. Do you have other SMTP services running on the server? Run Netstat in a command prompt to see which other application is binding to the IP address and port.
Regards,

Ian Margarone
MailEnable Support

tstrip111
Posts: 18
Joined: Tue Feb 10, 2015 2:52 pm

Re: Script Filters Caused Crash

Post by tstrip111 » Wed Sep 21, 2016 1:09 pm

Thanks Ian. I am running Enterprise Premium: 8.59

The crash may have been caused by my me starting and stopping the SMTP service several times. A clean reboot as resolved issues and they have not occurred since reboot.

Ill give the script filter a try again.

Thanks,

Post Reply