[SOLVED] (always) Problem with IMAP

Discussion forum for Enterprise Edition.
Post Reply
maxel91
Posts: 62
Joined: Sat Dec 10, 2016 1:10 am

[SOLVED] (always) Problem with IMAP

Post by maxel91 » Fri Feb 03, 2017 3:47 pm

Hi, we have ME Enterprise 9.54
We have also had problems with other versions using the IMAP.
Big email boxes (6gb example, difficult to more) freeze Outlook in all PC with these account configured. There are many times same message with IMAP error, "The connection was closed unexpectedly from the server". "Send/Receive" it's almost always blocked with subscription:

Image

This the folder of main folder:

Image

The problem, i see now, it's also with another mail with 200Mb and used from 15 devices. Can i delete some files(ex. file .nfy) for "recreate" boxes without create problem/delete mail?

What can i do?

Guido
Last edited by maxel91 on Mon Mar 27, 2017 10:25 am, edited 1 time in total.

MailEnable-Ian
Site Admin
Posts: 9227
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: (always) Problem with IMAP

Post by MailEnable-Ian » Mon Feb 13, 2017 4:43 am

Hi,

Upgrade to 9.60 as it contains IMAP improvements you need to apply. Then reassess from there.
Regards,

Ian Margarone
MailEnable Support

ebspain
Posts: 17
Joined: Sat Jan 31, 2015 10:00 am

Re: (always) Problem with IMAP

Post by ebspain » Wed Feb 15, 2017 8:26 am

Hello

we have a similar problem, and we use the latest 9.60 release ...for some reason the inbox doesn't synchronize. No errors, just no new messages! And if you look thru webmail you realized that there are new emails.

We finally found out that if you delete _index.xml it start to work again...but after a while it fails again. Is not practical to log into the server every 15 minutes to delete that file :? .

Any fix?

Regards,
Rafael

maxel91
Posts: 62
Joined: Sat Dec 10, 2016 1:10 am

Re: (always) Problem with IMAP

Post by maxel91 » Wed Feb 15, 2017 11:34 am

I installed 9.61 version.

No good news.

Mailenable, maybe this is an important help: when i go in webmail, if i login in a problematic postoffice, this don't load. I click login but no action and often Google Chrome says "Page doesn't answer, you want close it?"

Image

After 5 minutes, i enter in webmail but not mail for other 5 minutes (sometimes Inbox in webmail, when there is the problem, Inbox has 0 mail, i must refresh)

Image

Problems are linked. This problem it's every day, every hours.

HELP! :(
Last edited by maxel91 on Wed Feb 15, 2017 1:27 pm, edited 2 times in total.

ebspain
Posts: 17
Joined: Sat Jan 31, 2015 10:00 am

Re: (always) Problem with IMAP

Post by ebspain » Wed Feb 15, 2017 11:40 am

9.61??? Latest is 9.60...no?

maxel91
Posts: 62
Joined: Sat Dec 10, 2016 1:10 am

Re: (always) Problem with IMAP

Post by maxel91 » Wed Feb 15, 2017 12:39 pm

ebspain wrote:9.61??? Latest is 9.60...no?
http://www.mailenable.com/download.asp small changes

And there is a beta for 9.62

ebspain
Posts: 17
Joined: Sat Jan 31, 2015 10:00 am

Re: (always) Problem with IMAP

Post by ebspain » Wed Feb 15, 2017 12:43 pm

Thanks I checked it twice and I was wrong I have installed 9.61 already

maxel91
Posts: 62
Joined: Sat Dec 10, 2016 1:10 am

Re: (always) Problem with IMAP

Post by maxel91 » Wed Feb 15, 2017 2:14 pm

Now the problem! Here is the constant message that appears, both in outlook to thunderbird

Image


Log from K9MAIL:

K9-Mail version: 5.203
Device make: samsung
Device model: SM-G920F
Android version: 6.0.1

com.fsck.k9.mail.MessagingException: IO Error
at com.fsck.k9.mail.store.imap.ImapFolder.ioExceptionHandler(ImapFolder.java:1366)
at com.fsck.k9.mail.store.imap.ImapFolder.internalOpen(ImapFolder.java:163)
at com.fsck.k9.mail.store.imap.ImapFolderPusher$PushRunnable.openConnectionIfNecessary(ImapFolderPusher.java:330)
at com.fsck.k9.mail.store.imap.ImapFolderPusher$PushRunnable.run(ImapFolderPusher.java:155)
at java.lang.Thread.run(Thread.java:818)
Caused by: java.net.SocketTimeoutException
at java.net.PlainSocketImpl.read(PlainSocketImpl.java:484)
at java.net.PlainSocketImpl.access$000(PlainSocketImpl.java:37)
at java.net.PlainSocketImpl$PlainSocketInputStream.read(PlainSocketImpl.java:237)
at java.io.InputStream.read(InputStream.java:162)
at java.io.BufferedInputStream.fillbuf(BufferedInputStream.java:149)
at java.io.BufferedInputStream.read(BufferedInputStream.java:234)
at com.fsck.k9.mail.filter.PeekableInputStream.peek(PeekableInputStream.java:36)
at com.fsck.k9.mail.store.imap.ImapResponseParser.readResponse(ImapResponseParser.java:38)
at com.fsck.k9.mail.store.imap.ImapResponseParser.readResponse(ImapResponseParser.java:30)
at com.fsck.k9.mail.store.imap.ImapResponseParser.readStatusResponse(ImapResponseParser.java:88)
at com.fsck.k9.mail.store.imap.ImapConnection.executeSimpleCommand(ImapConnection.java:626)
at com.fsck.k9.mail.store.imap.ImapConnection.executeSimpleCommand(ImapConnection.java:612)
at com.fsck.k9.mail.store.imap.ImapFolder.executeSimpleCommand(ImapFolder.java:109)
at com.fsck.k9.mail.store.imap.ImapFolder.internalOpen(ImapFolder.java:145)
... 3 more


and another

K9-Mail version: 5.203
Device make: samsung
Device model: SM-G920F
Android version: 6.0.1

com.fsck.k9.mail.MessagingException: IO Error
at com.fsck.k9.mail.store.imap.ImapFolder.ioExceptionHandler(ImapFolder.java:1366)
at com.fsck.k9.mail.store.imap.ImapFolder.internalOpen(ImapFolder.java:163)
at com.fsck.k9.mail.store.imap.ImapFolderPusher$PushRunnable.openConnectionIfNecessary(ImapFolderPusher.java:330)
at com.fsck.k9.mail.store.imap.ImapFolderPusher$PushRunnable.run(ImapFolderPusher.java:155)
at java.lang.Thread.run(Thread.java:818)
Caused by: java.net.SocketTimeoutException
at java.net.PlainSocketImpl.read(PlainSocketImpl.java:484)
at java.net.PlainSocketImpl.access$000(PlainSocketImpl.java:37)
at java.net.PlainSocketImpl$PlainSocketInputStream.read(PlainSocketImpl.java:237)
at java.io.InputStream.read(InputStream.java:162)
at java.io.BufferedInputStream.fillbuf(BufferedInputStream.java:149)
at java.io.BufferedInputStream.read(BufferedInputStream.java:234)
at com.fsck.k9.mail.filter.PeekableInputStream.peek(PeekableInputStream.java:36)
at com.fsck.k9.mail.store.imap.ImapResponseParser.readResponse(ImapResponseParser.java:38)
at com.fsck.k9.mail.store.imap.ImapResponseParser.readResponse(ImapResponseParser.java:30)
at com.fsck.k9.mail.store.imap.ImapResponseParser.readStatusResponse(ImapResponseParser.java:88)
at com.fsck.k9.mail.store.imap.ImapConnection.executeSimpleCommand(ImapConnection.java:626)
at com.fsck.k9.mail.store.imap.ImapConnection.executeSimpleCommand(ImapConnection.java:612)
at com.fsck.k9.mail.store.imap.ImapFolder.executeSimpleCommand(ImapFolder.java:109)
at com.fsck.k9.mail.store.imap.ImapFolder.internalOpen(ImapFolder.java:145)
... 3 more

maxel91
Posts: 62
Joined: Sat Dec 10, 2016 1:10 am

Re: (always) Problem with IMAP

Post by maxel91 » Fri Feb 17, 2017 2:31 pm

After 30 min, impossible open emails...

Image

Image

Sasha_
Posts: 3
Joined: Mon Feb 27, 2017 7:55 am

Re: (always) Problem with IMAP

Post by Sasha_ » Mon Feb 27, 2017 8:06 pm

Same here!!

Is there any fix for this??

maxel91
Posts: 62
Joined: Sat Dec 10, 2016 1:10 am

Re: (always) Problem with IMAP

Post by maxel91 » Mon Mar 20, 2017 8:33 am

Sasha_ wrote:Same here!!

Is there any fix for this??
Try new version 9.70 , it should solve everything!

mosta2
Posts: 6
Joined: Mon Aug 21, 2017 6:07 pm

Re: [SOLVED] (always) Problem with IMAP

Post by mosta2 » Thu Aug 15, 2019 10:02 am

In my case a services restart fixes it

Post Reply