Email authentication and blocking

Discussion forum for Enterprise Edition.
Post Reply
jeffhsu
Posts: 49
Joined: Mon Apr 13, 2015 6:15 am

Email authentication and blocking

Post by jeffhsu » Fri Apr 06, 2018 3:41 am

I using ME Premium 10.15

How do I 100% force to accept users to authenticate using full email Only and not just user name?

I notice when at the block messages area, when there are records where spammers attempt to sign in using just user name eg. david (not full email)
any domain(s) with the same user name have the david email will be affected and will be blocked
Is this normal?

schmidtc63
Posts: 10
Joined: Thu Feb 08, 2018 10:38 pm

Re: Email authentication and blocking

Post by schmidtc63 » Sun Apr 08, 2018 4:38 pm

This is a function of the default Post Office, I think. If a user attempts to validate with no domain attached ("david" vs "david@mydomain.com"), the domain from the default Post Office is attached to the authorization attempt.

To do what you want to do:

First, make sure each of your post offices have the "Allow email addresses for usernames" checked (Post Office->Properties->Auth Policies tab).

Second, turn off the default postoffice: Servers->localhost->Properties->General tab. Uncheck Default PostOffice.

But, before you do any of this, you will need to notify your users that their email clients -- Outlook, Thunderbird, etc -- may have to have their settings modified to make sure the user's entire email address is being passed on an SMTP connection.

Also, anyone using the web mail interface will now have to include their entire email address as the username.

I think that should do it.

Post Reply