Problem setting up Caldav and SSL

sindrehi
Posts: 91
Joined: Fri Apr 15, 2005 7:58 am

Problem setting up Caldav and SSL

Postby sindrehi » Tue Jan 08, 2019 2:42 pm

Hi,

We have several problems setting up caldav with or without SSL.
1. The integrated Caldav setup is working. Its possible to set up a account by using http://domainname:8080/calendar.
Problem here is that for some calendar program we get error message "Caldav server does not support caldav-token.
Another problem is that Apple (iOS and OSX) dont support connecting to caldav without ssl.
2. Setting up caldav under iis is also problematic. Here I've added domain and binding to mailenable services in iis. Here I also enabled certificate.
In a browser I can navigate to https://caldav.domain.no:8443/calendar and it shows the mailenable caldav information page.
But when I try to add the same information like in attacment. On iOS or OSX we only get error message problem to verify account.

I need then a bit help to understand what could be wrong with the iis version. But another thing is that mailenable should start to enable SSL support for the integrated caldav solution (since many clients require this anyway)

Best Regards,

Pål Sindre HIåsen
Attachments
screendump_caldav_login_https_iis.PNG
screendump_caldav_login_https_iis.PNG (57.4 KiB) Viewed 288 times

MailEnable-Ian
Site Admin
Posts: 8800
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Problem setting up Caldav and SSL

Postby MailEnable-Ian » Tue Jan 08, 2019 10:48 pm

Hi,

1. The integrated Caldav setup is working. Its possible to set up a account by using http://domainname:8080/calendar.
Problem here is that for some calendar program we get error message "Caldav server does not support caldav-token.
Another problem is that Apple (iOS and OSX) dont support connecting to caldav without ssl.


Yes, Apple clients will only connect over SSL. This is a their restriction in their client and not MailEnable related. Since you are connecting via the "Synchronization" service over port 8080 you can enable SSL on port 8443 within the "Synchronization" properties window. Just ensure you open port 8443 in your firewall.

https://www.mailenable.com/documentation/10.0/Enterprise/Synchronization_-_General.html

You also need to configure your DNS infrastructure or create relevant SRV records to cater for Apple clients. Please review the following article:

https://www.mailenable.com/kb/content/article.asp?ID=ME020559

2. Setting up caldav under iis is also problematic. Here I've added domain and binding to mailenable services in iis. Here I also enabled certificate.
In a browser I can navigate to https://caldav.domain.no:8443/calendar and it shows the mailenable caldav information page.
But when I try to add the same information like in attacment. On iOS or OSX we only get error message problem to verify account.

I need then a bit help to understand what could be wrong with the iis version. But another thing is that mailenable should start to enable SSL support for the integrated caldav solution (since many clients require this anyway)


The error returned in indicating that the a verb is not allowed. This usually points to a URL scan or URL rewrite blocking the request. We would need to analyse the configuration in more detail along with log files to determine the cause. For this you will need to log a support ticket via the MailEnable support form. Its probably a better option for you configuring the synchronization service for CalDAV/CardDAV services.
Regards,

Ian Margarone
MailEnable Support

Who is online

Users browsing this forum: No registered users and 13 guests