Outlook calendar invites are failing Bayesian filter

Discussion forum for Enterprise Edition.
Post Reply
kevvyc
Posts: 8
Joined: Tue Jan 22, 2019 9:54 pm

Outlook calendar invites are failing Bayesian filter

Post by kevvyc » Tue Jan 29, 2019 10:42 pm

Hi -

All of the Outlook meeting invitations initiated by people at our company are being tagged with [SPAM] by Mail Enable. These users connect via IMAP (if that makes a difference.)

The header of one of them contained:

X-ME-Bayesian: 99.973343

A few others that were checked are similar.

What's the recommended approach for stopping this from occurring? Is there a way to stop ME from scanning emails that are generated by the post office?

Thank you.

Kevin

MailEnable-Ian
Site Admin
Posts: 8951
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Outlook calendar invites are failing Bayesian filter

Post by MailEnable-Ian » Fri Feb 08, 2019 3:19 am

Hi,

When you say "being tagged with [SPAM] by MailEnable", where do you see the tag? Is this in the message headers or in the message subject? Can you post up an example?
Regards,

Ian Margarone
MailEnable Support

kevvyc
Posts: 8
Joined: Tue Jan 22, 2019 9:54 pm

Re: Outlook calendar invites are failing Bayesian filter

Post by kevvyc » Mon Feb 11, 2019 7:55 pm

Hi Ian -

It's being placed in the email subject. I've uploaded two images - one is an image of the message in my inbox and the second is an image of the headers. What's interesting is "[SPAM] - test" doesn't appear in my Outlook inbox (I'm using MAPI,) however it appears everywhere else - in my account via web browser, phone (which uses IMAP) and any recipients outside of our company.

Thanks for your help.

Kevin
Attachments
image of email #2.jpg
image of email #2.jpg (36.55 KiB) Viewed 3540 times
image of email.jpg
image of email.jpg (5.51 KiB) Viewed 3540 times

MailEnable-Ian
Site Admin
Posts: 8951
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Outlook calendar invites are failing Bayesian filter

Post by MailEnable-Ian » Tue Feb 12, 2019 2:44 am

Hi,

The only option to add a subject prefix in MailEnable is to create a message content filter and add the action for "Add Subject Prefix". There is no other filter or security option that will mark the subject. Therefore if you do not have any filters configured, do you have any third party MTA pickup events enabled or other spam filters integrated within MailEnable?
Regards,

Ian Margarone
MailEnable Support

kevvyc
Posts: 8
Joined: Tue Jan 22, 2019 9:54 pm

Re: Outlook calendar invites are failing Bayesian filter

Post by kevvyc » Tue Feb 12, 2019 6:29 pm

Hi Ian -

Yes, we have filters in place. In the Bayesian one, we instruct it to add that prefix to the subject when the spam probability is over 90%.

What we're trying to understand is why almost all of the appointment invitations we create are getting a greater than 99.9% probability (as I believe is shown in my initial post) which is causing the prefix to be added. Thanks.

Kevin

MailEnable-Ian
Site Admin
Posts: 8951
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Outlook calendar invites are failing Bayesian filter

Post by MailEnable-Ian » Wed Feb 13, 2019 1:02 am

Hi,

How are you creating the invitations? The headers display that it was received from 127.0.0.1? Add the IP address of the client to the SMTP whitelist to bypass the filters.
Regards,

Ian Margarone
MailEnable Support

kiamori
Posts: 221
Joined: Wed Nov 04, 2009 1:39 am
Contact:

Re: Outlook calendar invites are failing Bayesian filter

Post by kiamori » Tue Feb 19, 2019 2:31 am

Turn on autotraning then send outlook calendar invites back and forth about 50 times and your problem will be solved.

kevvyc
Posts: 8
Joined: Tue Jan 22, 2019 9:54 pm

Re: Outlook calendar invites are failing Bayesian filter

Post by kevvyc » Thu Feb 21, 2019 4:19 pm

Thank you. I had looked into whitelisting the IPs as Ian suggested, however it didn't appear to work all of the time. The 127.0.0.1 appears because we have the option set to hide our local IP addresses.

I will perform the auto training and/or the manual training and see how it goes. Appreciate the help.

Kevin

Post Reply