Quotation mark kills MTA

Discussion forum for Enterprise Edition.
Post Reply
Jinglebens
Posts: 23
Joined: Mon Nov 05, 2007 9:56 am

Quotation mark kills MTA

Post by Jinglebens » Thu May 02, 2019 2:01 pm

We are running ME 8.62 Enterprise Premium. I noticed that if quotation is used in email, like this one for example: claudie"chanier@example.com then MTA service just stops processing anything. It is in running state, but just stuck, no log changes. Restarting it does not really help, as the message remains in SMTP inbound queue and only after deletion of that message MTA restarting resumes normal workflow. Any idea how to fix this issue?

Jinglebens
Posts: 23
Joined: Mon Nov 05, 2007 9:56 am

Re: Quotation mark kills MTA

Post by Jinglebens » Fri May 03, 2019 8:09 am

Today this issue re-appeared again. Here is what has happened:

- user has copied malformed email in Thunderbird: "m.jasniewski@example.com >> m.jasniewski"@example.com
- SMTP-Activity log reported it as:

05/03/19 09:09:38 SMTP-IN 4097549C35F8495989C82F82F2C4738C.MAI 1464 192.168.1.130 AUTH {blank} 334 PDc4NTYuLTkxODk3MTk5OUBEZWx0YU1haWwwMj4= 46 15
05/03/19 09:09:38 SMTP-IN 4097549C35F8495989C82F82F2C4738C.MAI 1464 192.168.1.130 AUTH {blank} 235 Authenticated CRAM-MD5 28 66 user.name
05/03/19 09:09:38 SMTP-IN 4097549C35F8495989C82F82F2C4738C.MAI 1464 192.168.1.130 MAIL MAIL FROM:<user.name@example.ch> SIZE=3647 250 Requested mail action okay, completed 43 51 user.name
05/03/19 09:09:38 SMTP-IN 4097549C35F8495989C82F82F2C4738C.MAI 1464 192.168.1.130 RCPT RCPT TO:<"m.jasniewski@example.com >> m.jasniewski"@example.com> 250 Requested mail action okay, completed 43 72 user.name
05/03/19 09:09:38 SMTP-IN 4097549C35F8495989C82F82F2C4738C.MAI 1464 192.168.1.130 DATA DATA 354 Start mail input; end with <CRLF>.<CRLF> 46 6 user.name
05/03/19 09:09:38 SMTP-IN C34448E0359D400DA7C7E30661743D33.MAI 1464 192.168.1.130 QUIT QUIT 221 Service closing transmission channel 42 6 user.name

-SMTP-Debug log reported it as

05/03/19 09:09:38 ME-I0149: [1364] 48F45C91760C4D6EBE8DD2E9F33EC39B.MAI was received successfully and delivery thread was initiated
05/03/19 09:09:38 ME-I0135: Authenticated User:user.name using Authentication Provider Credentials
05/03/19 09:09:38 ME-I0107: [1464] Relay Granted: Sender IP (192.168.1.130) is within an authorized IP range.
05/03/19 09:09:38 ME-I0149: [1464] 4097549C35F8495989C82F82F2C4738C.MAI was received successfully and delivery thread was initiated
05/03/19 09:09:38 ME-I0074: [1364] (Debug) End of conversation

- MTA-Activity log reported it as
05/03/19 09:09:38 [4097549C35F8495989C82F82F2C4738C.MAI] from (SMTP) [SMTP:"m.jasniewski@example.com]->
[SMTP:"m.jasniewski@example.com] Address Map resolved (masked) recipient.
- MTA-Debug log reported it as
05/03/19 09:09:38 ME-MTA-INFO : Routing message (4097549C35F8495989C82F82F2C4738C.MAI) from (SMTP) to 1 recipient(s).
- MTAFILTER-Report:
05/03/19 09:09:38 ME-I0092: 192.168.1.130 is registered in the system whitelist and was therefore excluded from checking

That's it. MTA died. Then the message was removed from SMTP inbound queue, MTA service restarted and mail delivery restored.

Please, help.

Post Reply