Serious problem with IMAP and Large mailboxes in ME 10.25

Discussion forum for Enterprise Edition.
Post Reply
kiamori
Posts: 224
Joined: Wed Nov 04, 2009 1:39 am
Contact:

Serious problem with IMAP and Large mailboxes in ME 10.25

Post by kiamori » Sun Jun 30, 2019 12:38 pm

I have a few clients that have very large mailboxes and this has always been somewhat of an issue with performance. Recently however, we've taken on some new clients through an acquisition and they have Smartermnail and since SM has just to many issues to deal with we've migrated these clients from a SM system to ME 10.25

One of the clients has a mailbox with 170,000 emails, yes I know too many. However the server is 64core 1.5TB ram 48 ssd drive in raid 10. Peak activity on the server is 1-2%, drive activity is 20-30%. However, IMAP crashes and we've traced it back to this large mailbox with 170,000 emails using sysinternals tools.

What can be done to resolve this or do I need to move this one client to another mail server?

kiamori
Posts: 224
Joined: Wed Nov 04, 2009 1:39 am
Contact:

Re: Serious problem with IMAP and Large mailboxes in ME 10.25

Post by kiamori » Tue Jul 09, 2019 10:36 pm

I did convince the client to archive some older mail into subfolders by year. once the inbox was below 80,000 messages the system performance was no longer an issue.

I still think this needs to be looked at in order to prevent issues like this for occuring in the future. I loaded the same inbox up via a imap migration to two other email systems and didnt have any issues at all with email clients loading the messages so the issue is specific to ME 10.25 and mailbox size in excess of 80,000 emails.

MailEnable-Ian
Site Admin
Posts: 8975
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Serious problem with IMAP and Large mailboxes in ME 10.25

Post by MailEnable-Ian » Wed Jul 10, 2019 1:20 am

Hi,

The best way forward would be to lodge a support ticket so we can gain access to log files etc. and the server if possible. If you still have the mailbox in this state then we would recommend enabling high level debug logging as well for the IMAP service to provide more information errors when they occur. the following article explains how to enable higher level debug logging for the MailEnable services.

https://www.mailenable.com/kb/content/article.asp?ID=me020585
Regards,

Ian Margarone
MailEnable Support

Post Reply