Auto-response not working for external emails

Discussion forum for Enterprise Edition.
Post Reply
obiwanconobi
Posts: 2
Joined: Mon Jul 29, 2019 10:37 am

Auto-response not working for external emails

Post by obiwanconobi » Thu Sep 17, 2020 10:02 am

Hello,

Our auto-response is not working for external emails. They work when we send emails internally to each other.

We make use of a smart host, and from looking at the logs, I believe this to be the issue. As you can see from the logs:

Code: Select all

09/17/20 10:57:16	Message 2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI locked for delivery.
09/17/20 10:57:16	Delivering 2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI to message store (1 Recipients)
09/17/20 10:57:16	[2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] Skipping autoresponse from PO=domain.co.uk MBX=connerp to [SMTP:POSTMASTER@domain.co.uk] as the message is flagged as system generated.
09/17/20 10:57:16	[2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] Checking message of size 5Kb for mailbox (connerp) on postoffice (domain.co.uk) with quota of -1Kb (current size 0Kb).
09/17/20 10:57:16	ProcessMailboxSpamSettings:: Mailbox spam filters are enabled
09/17/20 10:57:16	ProcessMailboxSpamSettings:: No action set for mailbox domain.co.uk/connerp, message spam value=0
09/17/20 10:57:16	[2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] DeliverToMailbox:: domain.co.uk/connerp, Sender=POSTMASTER@domain.co.uk Spam Rules Result=0
09/17/20 10:57:16	[2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] DeliverToMailbox:: Generating notification for message
09/17/20 10:57:16	[7204] Starting Direct Inserting [2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] into index (M:\Postoffices\domain.co.uk\MAILROOT\connerp\\Inbox\_index.xml).
09/17/20 10:57:16	[7204] Completed Direct Inserting [2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] into index (M:\Postoffices\domain.co.uk\MAILROOT\connerp\\Inbox\_index.xml).
09/17/20 10:57:16	[2B3E8C21A9FD4B86B7D388EBFF4CB3CF.MAI] Delivered message from [SMTP:POSTMASTER@domain.co.uk] to PO=domain.co.uk MBX=connerp FLD=\Inbox
It appears as though the messages are coming from postmaster, rather than the actual sender? Is there a way around this?

Post Reply