IMAP: Couldn't decrypt, error 80090330

Discussion forum for Enterprise Edition.
Post Reply
dcol
Posts: 173
Joined: Fri May 26, 2017 11:25 pm

IMAP: Couldn't decrypt, error 80090330

Post by dcol » Sat Aug 28, 2021 10:00 pm

What does 'Couldn't decrypt, error 80090330' mean? A web search found no explanations or resolutions
This happens a lot in the IMAP debug logs. Maybe I should just ignore these errors? I would still like to have an explanation.

MailEnable-Ian
Site Admin
Posts: 9545
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP: Couldn't decrypt, error 80090330

Post by MailEnable-Ian » Wed Sep 01, 2021 12:30 am

Hi,

We would really need the IMAP activity and debug log files. We would also need that you enable IMAP high level debug logging to exactly see what is happening at the time of the error. We suspect that the client maybe failing to authenticate over SSL and the client drops the connection. The best way for us to diagnose this in more detail is to lodge a support ticket. Details how to enable higher level debug logging can be found within the following article: https://www.mailenable.com/kb/content/article.asp?ID=me020585
Regards,

Ian Margarone
MailEnable Support

dcol
Posts: 173
Joined: Fri May 26, 2017 11:25 pm

Re: IMAP: Couldn't decrypt, error 80090330

Post by dcol » Wed Sep 01, 2021 3:59 pm

I personally use Thunderbird client with 5 mailboxes and I can replicate this error my just doing 'Get Messages' or starting the program. I turned on the high level debug and see the error happening, but still don't know why. I do not want to pay extra for a support ticket when I pay every year for maintenance. Especially when this is likely to be a problem with ME.

Here is a snippet from the debug log after I restarted the client
09/01/21 08:42:48 Authenticating User: dan@mydomain.com using Authentication Provider Credentials
09/01/21 08:42:48 [8244] 28 capability
09/01/21 08:42:48 [8244] 29 select "INBOX"
09/01/21 08:42:48 [Thread:9944]StreamXMLStoreIndexSerialiser::DeserialiseHook Elapse: 22, Item= N:\Mail Enable\Postoffices\mydomain.com\MAILROOT\dan\INBOX\_index.xml, Count=811, Instance=0
09/01/21 08:42:48 [8244] 30 UID fetch 1:* (FLAGS)
09/01/21 08:42:48 [8244] 31 IDLE
09/01/21 08:42:48 Couldn't decrypt, error 80090330
09/01/21 08:42:48 Socket (8228) closed by client.

MailEnable-Ian
Site Admin
Posts: 9545
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP: Couldn't decrypt, error 80090330

Post by MailEnable-Ian » Thu Sep 02, 2021 12:25 am

Hi,

I have setup Thunderbird (latest version 78.13.0) to connect to a test image over port 993 SSL IMAP and 465 SSL SMTP. I've issued multiple "Get Messages" and restarted the client and I cannot emulate the same errors. Can you please lodge a support under the category of "Upgrade" (free submission) and provide details for a technician to be able to connect to your MailEnable server to troubleshoot in more detail. Do you have a spam gateway/proxy filtering the IMAP traffic?
Regards,

Ian Margarone
MailEnable Support

dcol
Posts: 173
Joined: Fri May 26, 2017 11:25 pm

Re: IMAP: Couldn't decrypt, error 80090330

Post by dcol » Thu Sep 02, 2021 12:57 am

I do use Magicspam. Think maybe that could be doing it?

MailEnable-Ian
Site Admin
Posts: 9545
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP: Couldn't decrypt, error 80090330

Post by MailEnable-Ian » Thu Sep 02, 2021 2:21 am

Hi,

MagicSpam is an SMTP plugin and does not filter IMAP. You could enable Thunderbird client side logging as well to get more clues. Please see: http://www.mailenable.com/kb/content/article.asp?ID=ME02059. Will will need the full set of log files to troubleshoot in more detail. The best way forward to provide this is to log a support ticket and attach copies of the MailEnable IMAP activity and debug log files along with the Thunderbird log files.
Regards,

Ian Margarone
MailEnable Support

dcol
Posts: 173
Joined: Fri May 26, 2017 11:25 pm

Re: IMAP: Couldn't decrypt, error 80090330

Post by dcol » Fri Oct 08, 2021 3:39 pm

Now I am getting this error from a user using Outlook. Yesterday I did a repair on Outlook and changed to MAPI from IMAP. It worked all day, then today the error returned.
Also the article you recommended returns 404 error.

MailEnable-Ian
Site Admin
Posts: 9545
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: IMAP: Couldn't decrypt, error 80090330

Post by MailEnable-Ian » Mon Oct 11, 2021 12:08 am

Hi,

Apologies. Article here: https://www.mailenable.com/kb/content/article.asp?ID=ME020591
Regards,

Ian Margarone
MailEnable Support

Post Reply