MxUptime - ClamdScan Fails

Discussion, support and announcements for third party applications that work with MailEnable.
Post Reply
jwkeliz
Posts: 32
Joined: Fri Aug 08, 2008 7:33 pm

MxUptime - ClamdScan Fails

Post by jwkeliz » Fri Aug 08, 2008 7:52 pm

I have Mailenable vs 3.5.2 and just recently installed the free trial version 1.6.720 of MXscan. I loaded all the defaults however the activity monitor states taht ClamdScan Bypassed due to Permanant CLAMD Service Failure.

In addition when I try to run an antivirus update from the console I receive the error 5 [main] ? (604) C:\Program Files\MxUptime\MxScanME\Clam\bin\freshclam.exe
: *** fatal error - system shared memory version mismatch detected - 0x2D1E009C/ 0x8A88009C.
This problem is probably due to using incompatible versions of the cygwin DLL. Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version. The most recent version *should* reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution. Rebooting is also suggested if you
are unable to find another cygwin DLL.

I have looked and there is no other cygwin.dll. I installed the MXscan with all defaults and the cygwin.dll is in the c:\program files\MxUptime\MxScanME\clam\bin directory.

Has anyone else had this problem? I have uninstalled and reinstalled it but have the same problem.

polarisie
Posts: 696
Joined: Mon Mar 27, 2006 2:58 pm

Re: MxUptime - ClamdScan Fails

Post by polarisie » Sat Aug 09, 2008 2:45 am

jwkeliz wrote:I have Mailenable vs 3.5.2 and just recently installed the free trial version 1.6.720 of MXscan. I loaded all the defaults however the activity monitor states taht ClamdScan Bypassed due to Permanant CLAMD Service Failure.

In addition when I try to run an antivirus update from the console I receive the error 5 [main] ? (604) C:\Program Files\MxUptime\MxScanME\Clam\bin\freshclam.exe
: *** fatal error - system shared memory version mismatch detected - 0x2D1E009C/ 0x8A88009C.
This problem is probably due to using incompatible versions of the cygwin DLL. Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version. The most recent version *should* reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution. Rebooting is also suggested if you
are unable to find another cygwin DLL.

I have looked and there is no other cygwin.dll. I installed the MXscan with all defaults and the cygwin.dll is in the c:\program files\MxUptime\MxScanME\clam\bin directory.

Has anyone else had this problem? I have uninstalled and reinstalled it but have the same problem.
Hi

The build of ClamAV that is included with MxScan runs with Cygwin emulation. It is possible that you might have installed an application that used Cygwin (either in the past or currently). Quite a number of application use Cygwin and most of the time the only way to tell if to look inside the application folder

Your options in situations like these are to :

1. Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version
or
2. Try rebooting the server
3. Replace with a non cygwin of ClamAV (native Win32 builds) however this is not officially supported
MXSCAN :: AntiSpam & AntiVirus for MailEnable (now with Spamtrap/Honeypot!)
Built-in SpamAssassin, Clam, MessageSniffer, DNSBL, URLBL, DCC, Senderbase, SpamTrap, ShortCircuit, Content Filters, Disclamers, Archiving and more.
Visit www.mxuptime.com

jwkeliz
Posts: 32
Joined: Fri Aug 08, 2008 7:33 pm

Post by jwkeliz » Mon Aug 11, 2008 12:30 pm

Hello and thanks for your response. I have tried doing both of those suggestions and it still fails. Any other thoughts?

Thanks!

polarisie
Posts: 696
Joined: Mon Mar 27, 2006 2:58 pm

Post by polarisie » Mon Aug 11, 2008 12:38 pm

jwkeliz wrote:Hello and thanks for your response. I have tried doing both of those suggestions and it still fails. Any other thoughts?

Thanks!
Have you tried option #3? May i know which win32 build did you replace this with?
MXSCAN :: AntiSpam & AntiVirus for MailEnable (now with Spamtrap/Honeypot!)
Built-in SpamAssassin, Clam, MessageSniffer, DNSBL, URLBL, DCC, Senderbase, SpamTrap, ShortCircuit, Content Filters, Disclamers, Archiving and more.
Visit www.mxuptime.com

jwkeliz
Posts: 32
Joined: Fri Aug 08, 2008 7:33 pm

Post by jwkeliz » Mon Aug 11, 2008 1:23 pm

I have not tried option 3. Where would I find a "a non cygwin of ClamAV"

Thank you.

polarisie
Posts: 696
Joined: Mon Mar 27, 2006 2:58 pm

Post by polarisie » Mon Aug 11, 2008 1:46 pm

jwkeliz wrote:I have not tried option 3. Where would I find a "a non cygwin of ClamAV"

Thank you.
Hi

You can try this

1. Go to http://oss.netfarm.it/clamav/ and download the clamav-win32-XXX
2. Extract the contents of clamav-win32-XXX and replace with C:\Program Files\MxUptime\MxScanME\clam\bin
3. Copy C:\Program Files\MxUptime\MxScanME\clam\etc\*.* --> to --> C:\Program Files\MxUptime\MxScanME\clam\bin

Restart the service and then try again.

Cheers
MXSCAN :: AntiSpam & AntiVirus for MailEnable (now with Spamtrap/Honeypot!)
Built-in SpamAssassin, Clam, MessageSniffer, DNSBL, URLBL, DCC, Senderbase, SpamTrap, ShortCircuit, Content Filters, Disclamers, Archiving and more.
Visit www.mxuptime.com

jwkeliz
Posts: 32
Joined: Fri Aug 08, 2008 7:33 pm

Post by jwkeliz » Mon Aug 11, 2008 2:27 pm

That worked! Thanks so much!

trusnock
Posts: 132
Joined: Tue Jan 31, 2006 8:42 pm

Post by trusnock » Thu Oct 23, 2008 5:56 pm

Two things:

1) FYI, the non-Cygwin solution worked for us too. You have to remember to re-apply it every time you do an MxScan update, because the update will replace it with the Cygwin version.

2) The Cygwin ClamD seems to run fine on our server in the latest update (1.6.720.3), so we didn't have to apply the non-Cygwin version.

-Tom

Post Reply