Remote image not downloaded for your privacy

Discussions on webmail and the Professional version.
Post Reply
bm707
Posts: 11
Joined: Sat Apr 16, 2016 12:14 am

Remote image not downloaded for your privacy

Post by bm707 » Fri Dec 06, 2019 1:30 am

I just installed MailEnable Professional 10.28, and now almost every email message displayed in webmail has one or more boxes with the wording "Remote image not downloaded for your privacy". While not downloading external images by default is a great option, there are definitely cases where remote images need to be displayed, but there appears to be no way to do that. If I click on one of the privacy messages, it asks if I want to download remote images, but answering Yes does nothing. I also can't find a way to whitelist senders or disable this behavior in any way. How can remote images be displayed?

MailEnable-Ian
Site Admin
Posts: 9145
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Remote image not downloaded for your privacy

Post by MailEnable-Ian » Mon Dec 09, 2019 12:02 am

Hi,

Does the issue where it does not download the images occur on all messages? Or is it specific to one message? You can white list the sender address using the "white list" icon on the message preview pane.
Regards,

Ian Margarone
MailEnable Support

bm707
Posts: 11
Joined: Sat Apr 16, 2016 12:14 am

Re: Remote image not downloaded for your privacy

Post by bm707 » Mon Dec 09, 2019 12:06 am

Yes, it occurs on all messages from all senders to any recipient account on my server, regardless of whether or not the sender is whitelisted.

bm707
Posts: 11
Joined: Sat Apr 16, 2016 12:14 am

Re: Remote image not downloaded for your privacy

Post by bm707 » Sat Jan 04, 2020 3:42 am

I saw 10.29 is available, and the release notes mention remote images. I installed the new version, and it does NOT fix the issue. Remote images cannot display for any email message for any user with any browser for versions 10.28 and 10.29. This is really frustrating. When will it be fixed?

dbly
Posts: 52
Joined: Wed Aug 20, 2008 9:18 pm

Re: Remote image not downloaded for your privacy

Post by dbly » Tue Jan 07, 2020 3:02 pm

I can confirm that we are seeing the same behavior here after upgrading from 10.27 to 10.29

- Remote images don't load.
- Whitelisting has no effect, images still won't load.
- clicking on the text brings up a "Download Remote Image" dialog box, but clicking "Ok" does not cause the image to be downloaded.
- watching session in developer tools console shows no errors or attempts to download the missing image.

We need a resolution or instructions on how to downgrade the webmail.

Admin
Site Admin
Posts: 826
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Re: Remote image not downloaded for your privacy

Post by Admin » Wed Jan 08, 2020 6:02 am

Can you check the following registry key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Mail Enable\Mail Enable]
"Use MIME Library"=dword:00000001

This needs to be set to 1, but you may have it set to 0 which will cause the problem.

Also for Professional version there has been a fix for the default option to hide remote images when you double click an email.

https://www.mailenable.com/beta

bm707
Posts: 11
Joined: Sat Apr 16, 2016 12:14 am

Re: Remote image not downloaded for your privacy

Post by bm707 » Wed Jan 08, 2020 12:11 pm

Thank you. You were correct, the aforementioned registry key was set to 0, and changing it to "1" allowed all remote images to display. I never fiddled with the registry keys, so I'm not sure why it would have been set incorrectly. Regardless, now remote images always display for all email messages, even those in my spam folder, just as they did in 10.27 and earlier. So, how can I turn on the option to disable displaying remote images unless the user double-clicks to load them? In particular, I would never want to display remote images by default for spam. Is that in the beta version? Thanks again.

dbly
Posts: 52
Joined: Wed Aug 20, 2008 9:18 pm

Re: Remote image not downloaded for your privacy

Post by dbly » Wed Jan 08, 2020 4:57 pm

I can confirm that setting "Use MIME Library" to 1 solved our problems here.

I also tracked down to how it got set to zero on our server -- Back in 2015 when upgrading from version 8 to version 9 there was a problem with the then-new MIME library and on 19-November-2015 Ian had me disable it by setting it to zero to resolve some webmail rendering problems. It just never got changed back on after the library was fixed in the codebase.

Post Reply