Some network cards may cause communications failures with MailEnable


SYMPTOMS

Excessive 10054 Errors in logs and Windows Blue screen of death.

CAUSE

The following card/driver combinations have been identified in exposing undesirable behaviour with MailEnable:

Card Description Manufacturer Driver Version Driver Date Notes
VIA PCI 10/100Mb Fast Ethernet Adapters (VT6102 and VT6103) and VIA Rhine Adapters VIA Technologies 2.68.0.299 10/22/2001 Excessive 10054 Errors. Some network card/driver combinations randomly cause transmission failures with outbound data (Remote Connection Reset socket errors). This issue appears only with specific models of cards. Mail servers are more susceptible to 10054 errors because once the connection is dropped, the entire transaction is must be resent. Other operations, like file copies etc, typically accommodate such errors with connection retries, etc. This may be resolved by using manufacturers drivers.
MailEnable has reproduced this issue and can confirm the following solution:

Open Start|Settings|Network and Dialup Connections
Then select the network connection that is servicing MailEnable. Right click on it and select Properties.
Click on the Configure button.
Click the Advanced Tab
Change the setting for "Optimised for Performance" to Disabled.
Linksys LNE100TX(v5) Fast Ethernet Adapter LynkSys 2.10.402.2001 (not known) Can cause blue screen errors. May be resolved by using chip manufacturers drivers.

Note: Problems with VIA and LinkSys Cards outlined in this article have been confirmed to be issues with servers other than MailEnable.

RESOLUTION

VIA PCI 10/100Mb Fast Ethernet Adapters (VT6102 and VT6103) and VIA Rhine Adapters:

MailEnable has reproduced this issue and can confirm the following solution:

1. Open Start|Settings|Network and Dialup Connections
2. Then select the network connection that is servicing MailEnable. Right click on it and select Properties.
3. Click on the Configure button.
4. Click the Advanced Tab
5. Change the setting for "Optimised for Performance" to Disabled.

Linksys LNE100TX(v5) Fast Ethernet Adapter:

May be resolved by using chip manufacturers drivers.

MORE INFORMATION

Timeout issues with old 10/100 Netgear Network Cards: http://www.mailenable.com/kb/content/article.asp?ID=ME020041

When sending an email, Blue Screen of Death crash occurs: http://www.mailenable.com/kb/content/article.asp?ID=ME020057



Product:MailEnable (All Versions)
Category:Environment
Article:ME020077
Module:Other
Keywords:Network,card,NIC,VIA,PCI,Linksys,10054,error,errors
Class:PRB: Product Problem or Issue
Created:25/02/2003 1:47:00 PM
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable