SYMPTOMS
Web mail or web admin return the error " Type mismatch: 'session' ".
CAUSE
Some security applications (e.g. IIS lockdown tool) will change these settings to harden your IIS configuration. Unfortunately this hardening often conflicts with settings that are needed by MailEnable's web applications.
RESOLUTION
To resolve this issue, (re) configure Session State Management for
MailEnable's web applications.
This can be done as
follows:
1. Open the Internet Services Manager from Administrative
Tools
2. Select the web site that has been configured with
WebMail/WebAdmin
3. Right click on the WebMail/WebAdmin virtual directory and
choose Properties
4. Select Configuration
5. Select the Options tab
under Application Configuration
6. Verify that both Enable Session State is
selected
7. Select OK, then OK to close the properties window
More
information is available at the
following knowledgebase article:
http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3b242425
MailEnable's web mail or web admin require that Session State Management is enabled under Internet Information Server (IIS). When the MailEnable installation creates virtual directories, the properties for the new virtual directories are inherited from IIS's global settings.
MORE INFORMATION
When accessing web mail or web admin, IIS sub-authenticator errors appear in the Windows Event Log.: http://www.mailenable.com/kb/content/article.asp?ID=ME020273
How to manually create IIS Virtual Directories for web mail: http://www.mailenable.com/kb/content/article.asp?ID=ME020080
Product: | MailEnable (Pro-Any Pro-1.X Ent-Any Ent-1.X) |
Category: | Configuration |
Article: | ME020160 |
Module: | WebMail |
Keywords: | Type,mismatch,session,IIS,lockdown,web,mail,webmail,admin,error |
Class: | ERR: Product Error |
Created: | 1/07/2003 12:01:00 AM |
Revised: | Wednesday, May 4, 2016 |
Author: | MailEnable |
Publisher: | MailEnable |