SYMPTOMS
Mail messages sent via SMTP relay are not being placed in the SMTP outbound message queue.
CAUSE
The issue could be that there may be an entry missing from the address-map.tab file. The format of this file is outlined in the System Guide - http://www.mailenable.com/support/Mail%20Enable%20System%20Manual.pdf. It is a tab delimited file that maps source addresses to target addresses. It has a special entry in the file required to route non-local SMTP messages should appear in the file as follows:
[SMTP:*]{TAB}{TAB}0{TAB}System .
RESOLUTION
This entry needs to be the first line in
the file. It effectively means that any message that passes through the MTA as
a SMTP message needs to be routed back out the SMTP connector (the diagnostic
report should also confirm this). If this entry is not in the first few lines of the
file, add it to the top of the file. The file is tab delimited.
Here is
a technical explanation of what happens whenever a message is relayed through
MailEnable:
1. The message arrives from the mail client and is received
by the SMTP Connector. This is denoted in the SMTP log file with the transaction
type of SMTP-IN (indicates an inbound SMTP transaction).
E.g. 08/06/03 12:58:34 SMTP-IN 240 69.0.203.15
MAIL MAIL FROM:
2. Once all the data of the message has
been received, the message is picked up from the SMTP Inbound Queue by the MTA and
it is analysed to determine if it is local or if it needs to be sent back out
the SMTP Connector. The MTA requires a special entry in the ADDRESS-MAP.TAB file.
The first line of the ADDRESS-MAP.tab file should contain the
following:
Note: Address map.tab file is typically found in :
C:\Program Files\Mail Enable\Config and can be edited using notepad. It is a tab
delimited file.
3. If the domain name is not local, then
the MTA should pick it up and place it back in the SMTP Outbound
Queue.
4. The SMTP Connector will pick up the file from the SMTP
Connector Outbound Queue and send it to the remote host. An entry should be
found in the log file denoted as SMTP-OU transactions.
MORE INFORMATION
Diagnostic Report states "Invalid system entries" for Address Map Validity:http://www.mailenable.com/kb/content/article.asp?ID=ME020110
Error: Recipient is not defined in address map: http://www.mailenable.com/kb/content/article.asp?ID=ME020219
Diagnostic Utility reports Invalid System Entries: http://www.mailenable.com/kb/content/article.asp?ID=ME020215
MTA Debug or Activity Logs contain 'Address Map could not resolve recipient..' errors: http://www.mailenable.com/kb/content/article.asp?ID=ME020112
How to recover configuration data if a system corruption occurs or is accidently deleted?: http://www.mailenable.com/kb/content/article.asp?ID=ME020156
Error NO ADDRESS MAPS: CONTACT ADMINISTRATOR within web mail: http://www.mailenable.com/kb/content/article.asp?ID=ME020225
Product: | MailEnable (All Versions) |
Article: | ME020186 |
Module: | SMTP |
Keywords: | SMTP,queue,messages,smtp,outbound |
Class: | PRB: Product Problem or Issue |
Revised: | Wednesday, May 4, 2016 |
Author: | MailEnable |
Publisher: | MailEnable |