Snap-in errors when opening or closing MailEnable Management branch in the administration program


SYMPTOMS

"The selected snap-in did not initialize properly" is reported when attempting to access the "MailEnable Management" branch after loading the MailEnable Administration program.

"The snap-in below, failed to save." when trying to exit or save the MailEnable Administration program settings.

CAUSE

The installation of some applications moves the registered locatation of specific files to a new location as a means of forcing the installer to check the installation location for new copies of the file. Microsoft Office is an example of such an application (there are others). This can cause problems with the Microsoft Management Console (MMC), because it will use this stored path (particularly when the MMC is started or when attempting to close the MMC).

RESOLUTION

The following suggestions should resolve the issue:

Re-register MSVBVM60.DLL

A potential solution to the problem is to ensure that the file MSVBVM60.DLL is located in the SYSTEM32 directory. If it is not, replace the file and use the regsvr32 application to register the DLL.

1. Close all applications including the MMC
2. Open a command prompt and navigate to your Winnt\System32 directory3.

Then type:
regsvr32 MSVBVM60.DLL

This should resolve the issue. It is most likely that some application, installed after MailEnable, has changed this registry key. From what we have determined, it may be Microsoft Office doing this in order to require the CD to be inserted. Validate the PATH Environment VariableFrom the Windows Command Prompt, display the Windows PATH environment variable.

This can be done as follows:
echo %path% or type:
SET
at the command prompt.

Check the path for any anomalies or missing directories and ensure that the following directories (or their equivalents) are included in the PATH. 

C:\PROGRA~1\MAILEN~1\BIN;C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem

Information on managing the PATH variable follow:

1. Open the Computer Management applet at Start|Programs|Administrative Tools|Computer Management
2. Right Click on Computer Management (Local) and select Properties.
3. Select the Advanced tab. Click on the Environment Variables button.
4. In the System Variables list, scroll down to find the "Path" environment variable, then highlight it
and select Edit.
5. The Path environment variable should contain a semi-colon delimited list of directory names.
6. Ensure that that the short path (8.3) equivalent of C:\Program Files\Mail Enable\Bin (depending on the installation path) appears in this list.
7. Accept all changes and close the Computer Management applet.

MORE INFORMATION

'Internet Explorer Script Error' when running the MailEnable Administration Program: http://www.mailenable.com/kb/content/article.asp?ID=ME020205

The Administration Program Application will not run: http://www.mailenable.com/kb/content/article.asp?ID=ME020009

Re-registering the MailEnable Administration Program components: http://www.mailenable.com/kb/content/article.asp?ID=ME020060

Using the MailEnable MEInstaller.exe utility:  http://www.mailenable.com/kb/content/article.asp?ID=ME020314



Product:MailEnable (All Versions)
Article:ME020208
Module:General
Keywords:MMC,snap-ins,Mailenable,management,console,administration,program,snap,in
Class:ERR: Product Error
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable